summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMorten Linderud2017-09-06 01:38:33 +0200
committerMorten Linderud2017-09-06 01:38:33 +0200
commita49193fdfd5df5937e765978408bbf6d79ba1b03 (patch)
treed751fe7ce0ae05550458178e3ae94371f8f006a9 /PKGBUILD
downloadaur-a49193fdfd5df5937e765978408bbf6d79ba1b03.tar.gz
dmenu-extended: renamed to dmenu-extended-git
Signed-off-by: Morten Linderud <morten@linderud.pw>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18b7d0cfa7bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Morten Linderud <morten@linderud.pw>
+# Contributor: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
+
+pkgname=dmenu-extended-git
+_pkgname=dmenu-extended
+pkgver=r280.4f0395f
+pkgrel=1
+pkgdesc='An extension to dmenu for quickly opening files and folders.'
+url='https://github.com/markjones112358/dmenu-extended'
+license=('MIT')
+arch=('any')
+depends=('python' 'dmenu')
+makedepends=('git')
+provides=('dmenu-extended')
+conflicts=('dmenu-extended')
+source=("git+https://github.com/markjones112358/dmenu-extended.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: