summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShizcow2020-06-30 19:58:11 -0600
committerShizcow2020-06-30 19:58:11 -0600
commit88fc4ff1fd00d2ab88564ecc641b40b8e25bf079 (patch)
treeb372d13e55aa0d02f82391672f49d1a5a918aaa3 /PKGBUILD
downloadaur-88fc4ff1fd00d2ab88564ecc641b40b8e25bf079.tar.gz
First commit, latched onto dev branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24fb6f9fec0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Devin Pohl <pohl.devin@gmail.com>
+
+# -------------------------------------------------------
+# PLUGINS
+# -------------------------------------------------------
+# If you'd like to compile in plugins, add the names here
+# For a list of available plugins, see the git repo
+# or run `make plugins` in the cloned repo
+PLUGINS=""
+
+_pkgname=dmenu
+pkgname=$_pkgname-rs
+pkgver=5.2.2.0.ged9fdd9
+pkgrel=1
+pkgdesc="The development branch of dmenu-rs. Likely has unstable features."
+arch=('i686' 'x86_64')
+url="https://github.com/Shizcow/dmenu-rs"
+license=('MIT')
+depends=('sh' 'libxinerama' 'libxft')
+makedepends=('rust' 'git' 'clang')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed 's/-/./g'
+}
+
+prepare() (
+ cd dmenu-rs
+ git config advice.detachedHead false
+)
+
+build() (
+ cd dmenu-rs
+ git checkout develop
+ make PLUGINS="$PLUGINS"
+)
+
+package() (
+ cd $pkgname
+ make PREFIX=/usr DESTDIR="$pkgdir" PLUGINS="$PLUGINS" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+) \ No newline at end of file