summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjdev0822023-07-16 16:39:59 -0500
committerjdev0822023-07-16 16:39:59 -0500
commita835c3c14250a96576cc42680e37fc6d4156d63a (patch)
treec7bf53d7e4ee1d991955c5f8504d06c20083a608 /PKGBUILD
parent27b2ae6344a841ddb081f6e1bdbb446e757438fa (diff)
downloadaur-dmenu-wayland-git.tar.gz
fix: remove dwm symlinks and update metadata
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f92859063ff5..60fc12b13c60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: jdev082 <jdev0894@gmail.com>
# Maintainer: Davide Depau <davide@depau.eu>
# Contributor: Andrew Conrad <aconrad103@gmail.com>
# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
@@ -9,8 +10,8 @@
_pkgname=dmenu-wayland
pkgname=$_pkgname-git
-pkgver=4.2.1.r40.b76d594
-pkgrel=1
+pkgver=4.2.1.r59.a380201
+pkgrel=2
pkgdesc="Wayland port of a generic menu for X"
url="https://github.com/nyyManni/dmenu-wayland"
arch=('i686' 'x86_64')
@@ -18,8 +19,8 @@ license=('MIT')
depends=('wayland' 'wayland-protocols' 'cairo' 'pango' 'libxkbcommon' 'glib2')
makedepends=('git' 'meson' 'ninja')
# Not providing "dmenu" is intented: it does not provide a "dmenu" command, it's "dmenu-wl"
-provides=(dmenu-wayland dmenu)
-conflicts=(dmenu-wayland dmenu)
+provides=(dmenu-wayland)
+conflicts=(dmenu-wayland)
source=(git+https://github.com/nyyManni/dmenu-wayland.git)
sha256sums=('SKIP')
@@ -51,11 +52,4 @@ package() {
cd $_pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-
- msg2 "Installing symlinks for dmenu..."
- # Install symlinks to provide dmenu
- ln -sf "dmenu-wl" "$pkgdir/usr/bin/dmenu"
- ln -sf "dmenu-wl_run" "$pkgdir/usr/bin/dmenu_run"
- ln -sf "dmenu-wl_path" "$pkgdir/usr/bin/dmenu_path"
- ln -sf "dmenu-wl.1.gz" "$pkgdir/usr/share/man/man1/dmenu.1.gz"
}