summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavide Depau2019-04-19 22:42:48 +0200
committerDavide Depau2019-04-19 22:42:48 +0200
commit4b532c04b6c8969758c7f9cb4e73713362774eb4 (patch)
tree7e28f58734a6af8f3d257ec046ac640e26ab593a /PKGBUILD
parentf2e9a8b6380a1ecd36df493fddf3a02091b938f0 (diff)
downloadaur-4b532c04b6c8969758c7f9cb4e73713362774eb4.tar.gz
Use @nyyManni's dmenu-wayland
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a4562877f3c..b35e79c82780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,34 @@
-# Maintainer: Andrew Conrad <aconrad103@gmail.com>
-# Contributor: Håvard Pettersson <mail@haavard.me>
+# Maintainer: Davide Depau <davide@depau.eu>
+# Contributor: Andrew Conrad <aconrad103@gmail.com>
+# Contributor: Håvard Pettersson <mail@haavard.me>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Thorsten Töpper <atsutane-tu@freethoughts.de>
# Contributor: Thayer Williams <thayer@archlinux.org>
# Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
-_pkgname=dmenu
-pkgname=$_pkgname-wayland-git
-pkgver=503.6e08b77
+_pkgname=dmenu-wayland
+pkgname=$_pkgname-git
+pkgver=4.2.1.r26.de4fcbf
pkgrel=1
pkgdesc="Wayland port of a generic menu for X"
-url="https://github.com/michaelforney/dmenu"
+url="https://github.com/nyyManni/dmenu-wayland"
arch=('i686' 'x86_64')
license=('MIT')
-depends=('sh' 'wld')
-makedepends=('git' 'libx11' 'swc-git')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=(git://github.com/michaelforney/$_pkgname)
+depends=('wayland-protocols' 'cairo' 'pango' 'libxkbcommon' 'glib2')
+makedepends=('git')
+# Not providing "dmenu" is intented: it does not provide a "dmenu" command, it's "dmenu-wl"
+provides=(dmenu-wayland)
+conflicts=(dmenu-wayland)
+source=(git+https://github.com/nyyManni/dmenu-wayland.git)
sha256sums=('SKIP')
pkgver() {
cd $srcdir/$_pkgname
- echo $(git rev-list --count wayland).$(git rev-parse --short wayland)
+ base_ver=$(cat config.mk | grep VERSION | head -n1 | awk '{ print $3 }')
+ git_ver=$(printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
+
+ echo "$base_ver.$git_ver"
}
prepare() {
@@ -32,6 +37,9 @@ prepare() {
if [[ -f ${SRCDEST}/config.h ]]; then
cp "${SRCDEST}/config.h" .
fi
+
+ sed -i 's/^PREFIX = .*$/PREFIX = \/usr/' config.mk
+ sed -i 's/lib\/x86_64-linux-gnu/lib/g' config.mk
}
build(){