summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavide Depau2019-05-13 09:20:35 +0200
committerDavide Depau2019-05-13 09:20:35 +0200
commit93d036d9ae6b7e43c689df76a42bc03f5e6b1161 (patch)
treeae4ae8b8591a7daaa4abf58c7361c9affde61439 /PKGBUILD
parent4b532c04b6c8969758c7f9cb4e73713362774eb4 (diff)
downloadaur-93d036d9ae6b7e43c689df76a42bc03f5e6b1161.tar.gz
Switch to Meson build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b35e79c82780..afefbe60dc91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,14 @@
_pkgname=dmenu-wayland
pkgname=$_pkgname-git
-pkgver=4.2.1.r26.de4fcbf
+pkgver=.r34.88f1766
pkgrel=1
pkgdesc="Wayland port of a generic menu for X"
url="https://github.com/nyyManni/dmenu-wayland"
arch=('i686' 'x86_64')
license=('MIT')
depends=('wayland-protocols' 'cairo' 'pango' 'libxkbcommon' 'glib2')
-makedepends=('git')
+makedepends=('git' 'meson' 'ninja')
# Not providing "dmenu" is intented: it does not provide a "dmenu" command, it's "dmenu-wl"
provides=(dmenu-wayland)
conflicts=(dmenu-wayland)
@@ -37,20 +37,18 @@ prepare() {
if [[ -f ${SRCDEST}/config.h ]]; then
cp "${SRCDEST}/config.h" .
fi
-
- sed -i 's/^PREFIX = .*$/PREFIX = \/usr/' config.mk
- sed -i 's/lib\/x86_64-linux-gnu/lib/g' config.mk
}
build(){
- cd $srcdir/$_pkgname
- make \
- X11INC=/usr/include/X11 \
- X11LIB=/usr/lib/X11
+ cd $srcdir
+ arch-meson ${_pkgname} build
+ ninja -C build
}
package() {
- cd $srcdir/$_pkgname
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ cd $srcdir
+ DESTDIR="$pkgdir" ninja -C build install
+
+ cd $_pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}