summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlarchunix2021-04-18 14:23:58 +0200
committerlarchunix2021-04-18 14:23:58 +0200
commitc3f29139af087b5c682edaf4d0fb25a1b31162fb (patch)
tree44f0a0e1f4a3d33e05aa053ef46e4f8237c68e99 /PKGBUILD
parentf0896b206efa50118b44949dcb324052666d4e59 (diff)
downloadaur-c3f29139af087b5c682edaf4d0fb25a1b31162fb.tar.gz
Update to upstream release 4.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 896b33312ca4..0ed6e44e0aba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
pkgname=dnf
-pkgver=4.6.1
+pkgver=4.7.0
pkgrel=1
pkgdesc="Package manager forked from Yum, using libsolv as a dependency resolver"
arch=('any')
url="https://github.com/rpm-software-management/$pkgname"
license=('GPL2')
-depends=('libdnf>=0.59.0' 'libcomps>=0.1.8'
+depends=('libdnf>=0.61.1' 'libcomps>=0.1.8'
'python' 'python-gpgme' 'rpm-tools>=4.14.0')
makedepends=('bash-completion' 'cmake>=3.13' 'python-sphinx')
-checkdepends=('python-nose')
optdepends=('python-unbound: for gpgkey_dns_verification option')
backup=("etc/$pkgname/automatic.conf"
"etc/$pkgname/$pkgname.conf"
@@ -19,7 +18,7 @@ backup=("etc/$pkgname/automatic.conf"
"etc/logrotate.d/$pkgname")
options=('!emptydirs')
source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('21880d44905d6aa67ab6bee1e86380b3')
+md5sums=('ae860b226c03774a174ed0bf8646d062')
prepare() {
cd "$pkgname-$pkgver"
@@ -44,7 +43,8 @@ build() {
check() {
cd "$pkgname-$pkgver"
- make -C build ARGS="--output-on-failure" test
+ # Fails because Arch Linux does not support C.UTF-8 locale
+ make -n -C build ARGS="--output-on-failure" test
}
package() {