summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlarchunix2018-06-26 17:58:33 +0200
committerlarchunix2018-06-26 17:58:33 +0200
commitf4600afa4df265c6d6a541b406b9cef58bfd6dae (patch)
treed54cc9cffc7b5019061f22c4c2da2e94f8304af1 /PKGBUILD
parent80ccd1e203aa6ea0d18a05e45b5f59733c21e3c2 (diff)
downloadaur-f4600afa4df265c6d6a541b406b9cef58bfd6dae.tar.gz
Update to upstream release 3.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f87491012415..97eea22f7574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
pkgname=dnf
-pkgver=2.7.5
+pkgver=3.0.1
pkgrel=1
pkgdesc="Package manager forked from Yum, using libsolv as a dependency resolver"
arch=('any')
url="https://github.com/rpm-software-management/$pkgname"
license=('GPL2' 'GPL')
-depends=('libdnf>=0.10.1' 'libcomps' 'librepo' 'rpm-org'
- 'python' 'python-iniparse' 'python-gpgme')
+depends=('libdnf>=0.14.0' 'libcomps>=0.1.8' 'libmodulemd>=1.4.0'
+ 'librepo>=1.9.0'
+ 'python' 'python-gobject' 'python-gpgme' 'python-iniparse'
+ 'python-smartcols'
+ 'rpm-org')
makedepends=('bash-completion' 'cmake' 'python-sphinx')
checkdepends=('python-nose')
backup=("etc/$pkgname/automatic.conf"
"etc/$pkgname/$pkgname.conf")
-source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('a57be9b448b4093c0943170c4a021155')
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ "$pkgname-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch")
+md5sums=('f48fa08bfe26cf34ba0561f623fdee1c'
+ '51bbd2fd1ab2c11057c833adecb8b5fa')
prepare() {
cd "$pkgname-$pkgver"
rm -rf build
mkdir build
+
+ patch -p1 < "$srcdir/$pkgname-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch"
}
build() {
@@ -40,7 +47,8 @@ package() {
cd "$pkgname-$pkgver"/build
make DESTDIR="$pkgdir/" install
- rm "$pkgdir/usr/share/man/man8/yum.8"
+ rm "$pkgdir/usr/share/man/man8/yum.8" \
+ "$pkgdir/usr/share/man/man5/yum.conf.5"
ln -s $pkgname-3 "$pkgdir/usr/bin/$pkgname"
ln -s $pkgname-automatic-3 "$pkgdir/usr/bin/$pkgname-automatic"