summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Candau2022-09-12 22:24:44 +0200
committerRobin Candau2022-09-12 22:24:44 +0200
commit815d69c6fd6933fc50ba6a474bc4fc644d99510a (patch)
tree52fc8c5a9325afa2aa718e830f4a18fcec7060ed /PKGBUILD
parent840ae9730b0c3fa3b5d8ee40128179bda469cef1 (diff)
downloadaur-815d69c6fd6933fc50ba6a474bc4fc644d99510a.tar.gz
Added aarch64 (arm64) architecture support and corrected the licence
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c7ab0167c33..245711d9bfd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@
pkgname=dnote-server-bin
_pkgname="${pkgname%-bin}"
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A simple command line notebook for programmers (Server)"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://www.getdnote.com/"
-license=('GPL3')
+license=('AGPL3')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dnote/dnote/releases/download/server-v${pkgver}/dnote_server_${pkgver}_linux_amd64.tar.gz")
-sha256sums=('ed10a3a0484c3fce800faa0f786b1656b9edbf66a0aeeb3261053d78496b8077')
+source_x86_64=("${_pkgname}-${pkgver}-amd64.tar.gz::https://github.com/dnote/dnote/releases/download/server-v${pkgver}/dnote_server_${pkgver}_linux_amd64.tar.gz")
+source_aarch64=("${_pkgname}-${pkgver}-arm64.tar.gz::https://github.com/dnote/dnote/releases/download/server-v${pkgver}/dnote_server_${pkgver}_linux_arm64.tar.gz")
+sha256sums_x86_64=('ed10a3a0484c3fce800faa0f786b1656b9edbf66a0aeeb3261053d78496b8077')
+sha256sums_aarch64=('0613d5bdaab7cb067420e3b32e5a676ec0b14a071b36014cd646d81c72dbc137')
package() {
cd "${srcdir}"