summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Candau2022-09-11 19:08:51 +0200
committerRobin Candau2022-09-11 19:08:51 +0200
commit840ae9730b0c3fa3b5d8ee40128179bda469cef1 (patch)
tree54009e829cd8f95c8da3a2373f5ebbd838810de6 /PKGBUILD
parentd38b7ed07ebbc548ee796ded5a00108095eceef7 (diff)
downloadaur-840ae9730b0c3fa3b5d8ee40128179bda469cef1.tar.gz
New maintainer, update to V2.0.1, added 'dnote-server' to conflicts, removed the 'glibc' dependency, improved the PKGBUILD globally
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8fa8d1c51b1..7c7ab0167c33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Maintainer: Robin Candau <robincandau[at]protonmail[dot]com>
+# Contributor: Dimitris Kiziridis <ragouel[at]outlook[dot]com>
pkgname=dnote-server-bin
-pkgver=1.0.4
+_pkgname="${pkgname%-bin}"
+pkgver=2.0.1
pkgrel=1
pkgdesc="A simple command line notebook for programmers (Server)"
arch=('x86_64')
url="https://www.getdnote.com/"
-license=('AGPL3')
-provides=('dnote-server')
-depends=('glibc')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/dnote/dnote/releases/download/server-v${pkgver}/dnote_server_${pkgver}_linux_amd64.tar.gz")
-sha256sums=('0c35a5d1affa45a5406f816344375c1541f7b602d0be8e765af6a2db21a8ecbc')
+license=('GPL3')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dnote/dnote/releases/download/server-v${pkgver}/dnote_server_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('ed10a3a0484c3fce800faa0f786b1656b9edbf66a0aeeb3261053d78496b8077')
package() {
- install -Dm755 "$srcdir/dnote-server" -t "${pkgdir}/usr/bin/"
- install -Dm644 "${srcdir}/README.md" -t "${pkgdir}/usr/share/doc/"
-} \ No newline at end of file
+ cd "${srcdir}"
+
+ install -Dm 755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+}