summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRemi Gacogne2016-06-27 11:37:18 +0200
committerRemi Gacogne2016-06-27 11:37:18 +0200
commit7f084311ba15ca597f35765313e0f740e56ea46c (patch)
tree4d2044395f72991ec7875c220e78e9a641e8edba /PKGBUILD
parent15e50395d64be331549ac21263b11164d35f627e (diff)
downloadaur-7f084311ba15ca597f35765313e0f740e56ea46c.tar.gz
The service file doesn't exist yet in package(). Thanks to DenSchub!
Also replace lua52 dependency to lua, since it's now correctly detected.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6985f683596..9d58b47fba0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Remi Gacogne <rgacogne-arch at coredump dot fr>
pkgname=dnsdist
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Highly DNS-, DoS- and abuse-aware loadbalancer'
arch=('i686' 'x86_64')
url='http://dnsdist.org/'
@@ -13,15 +13,10 @@ sha512sums=('89a926900c0fb16ed64dce1bc5a075899633ede7e4539bc17b388d4535aa751f264
'SKIP')
validpgpkeys=('B76CD4671C0968BAA87DE61C5E50715BF2FFE1A7') # Pieter Lexis <pieter.lexis@powerdns.com>
makedepends=('boost' 'git' 'pandoc' 'ragel')
-depends=('libedit' 'libsodium' 'libsystemd' 'lua52' 'protobuf')
+depends=('libedit' 'libsodium' 'libsystemd' 'lua' 'protobuf')
provides=('dnsdist')
conflicts=('dnsdist')
-prepare() {
- cd "${pkgname}-${pkgver}"
- sed -i 's,ExecStart=/usr/bin/dnsdist --supervised --disable-syslog,ExecStart=/usr/bin/dnsdist --supervised --disable-syslog -u nobody -g nobody,' dnsdist.service
-}
-
build() {
cd "${pkgname}-${pkgver}"
./configure \
@@ -35,6 +30,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i 's,ExecStart=/usr/bin/dnsdist --supervised --disable-syslog,ExecStart=/usr/bin/dnsdist --supervised --disable-syslog -u nobody -g nobody,' dnsdist.service
make DESTDIR="${pkgdir}" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}