summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBin Jin2023-06-30 00:35:27 +0800
committerBin Jin2023-06-30 00:35:27 +0800
commit08116b52cf8bc6be88638faf886658840b8db448 (patch)
tree64f5b67caff13434ee4fc1ecabceb5ca5cb24bfa /PKGBUILD
parent2d1c6b7a4c90c364f7da5ea4dfb11414ae4a528c (diff)
downloadaur-08116b52cf8bc6be88638faf886658840b8db448.tar.gz
set version string
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 043b013ca302..c09b5a1dca52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dnsproxy
pkgver=0.50.2
-pkgrel=1
+pkgrel=2
pkgdesc="Simple DNS proxy with DoH, DoT, DoQ and DNSCrypt support"
arch=('x86_64')
url="https://github.com/AdguardTeam/dnsproxy"
@@ -19,7 +19,7 @@ backup=($_conf)
build(){
cd "${srcdir}/${pkgname}-${pkgver}"
- go build -mod=vendor -v -trimpath -buildmode=pie
+ go build --ldflags "-s -w -X main.VersionString=${pkgver}" -mod=vendor -v -trimpath -buildmode=pie
}
package() {