summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBin Jin2023-05-31 17:12:54 +0800
committerBin Jin2023-05-31 17:12:54 +0800
commit188d3d80128fe9e2f66d0e09c00b77d6a79bf75a (patch)
tree030ff1824fe8cc15252335e06dfb99fbd32d78cb /PKGBUILD
parent584a1a40605b477e06ed2e7338303266980741a4 (diff)
downloadaur-188d3d80128fe9e2f66d0e09c00b77d6a79bf75a.tar.gz
initial commit (adguard-0.49.1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 27 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 335a395dc3b9..dc469afd5b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
-# Maintainer: Edward Pacman <micro <dot> fedora AT gmail DOT com>
+# Contributor: Whyme Lyu <callme5long@gmail.com>
+
pkgname=dnsproxy
-pkgver=git+f03234a
+pkgver=0.49.1
pkgrel=1
-pkgdesc="A simple DNS proxy server, runing on multiple platform"
-arch=('any')
-url="https://github.com/vietor/dnsproxy"
-license=('GPL')
-makedepends=('git'
- 'make')
-source=("git+https://github.com/vietor/dnsproxy.git")
-md5sums=("SKIP")
+pkgdesc="Simple DNS proxy with DoH, DoT, DoQ and DNSCrypt support"
+arch=('x86_64')
+url="https://github.com/AdguardTeam/dnsproxy"
+license=('Apache')
+conflicts=('dnsproxy-bin' 'dnsproxy-adguard')
+source=("dnsproxy.service"
+ "dnsproxy.yaml"
+ "https://github.com/AdguardTeam/dnsproxy/archive/v${pkgver}.tar.gz")
+makedepends=("go" "git")
+sha256sums=('565eea9808589ecafa81f2229ac1f85b39028e26d488a9a7c0b51afc43d7f42b'
+ '72937969cc68182672e945fb26a6e350772a421463a4593c113d2f89af0b922c'
+ 'c587a7e88660c879f738df1ffcbf0402928a0c04ec0f148e385017f176e8ba14')
-prepare() {
- cd "$pkgname"
- git submodule init
- git submodule update
-}
+_conf=etc/dnsproxy/dnsproxy.yaml
+backup=($_conf)
-build() {
- cd "$pkgname"
- make
+build(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ go build
}
package() {
- cd "$pkgname"
- mkdir -p "$pkgdir/usr/bin"
- cp src/dnsproxy $pkgdir/usr/bin
-}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 dnsproxy "${pkgdir}/usr/bin/dnsproxy"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/license/dnsproxy/LICENSE
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/dnsproxy/README.md
+ install -Dm644 "${srcdir}/dnsproxy.yaml" "$pkgdir/$_conf"
+ install -Dm644 "${srcdir}/dnsproxy.service" "${pkgdir}/usr/lib/systemd/system/dnsproxy.service"
+}