summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLenni vH2020-08-18 18:03:22 +0200
committerLenni vH2020-08-18 18:03:22 +0200
commit4b78582491c876b6bd31c2055396644564f056c5 (patch)
treee3e296f220da95db609a0b2eea6f07a594654513 /PKGBUILD
parentf53e14cee3b4fb5d91a483bf7f0e9ca8a87c5810 (diff)
downloadaur-4b78582491c876b6bd31c2055396644564f056c5.tar.gz
updated to 6.3p2, added example config, fixed some Makefile issues
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c43f3f18f8b1..3df94bcf2ab7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
-# Maintainer: Stephen Gregoratto <dev@sgregoratto.me>
+# Maintainer: lennivh24@gmail.com
pkgname=doas
-pkgver=6.2p2
+pkgver=6.3p2
pkgrel=1
-pkgdesc="Port of OpenBSD's doas(1), an alternative to sudo(1)"
-license=('custom: ISC')
+pkgdesc="A port of OpenBSD's doas(1), an alternative to sudo(1)"
+license=('BSD')
url="https://github.com/slicer69/doas"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-depends=('pam')
+depends=('pam' 'bison')
+backup=('etc/doas.conf'
+ 'etc/pam.d/doas')
provides=('doas')
replaces=('opendoas' 'opendoas-git')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
- 'doas.patch'
- 'doas-pam')
-sha256sums=('b8dc7e3357d12335ab6890d8303523862112416136bb50f170400cf5746dfd16'
- '44c737230bb5dcd797a856c3298a4154d49fea2c1823a0531dcb43076f42caee'
- 'f61f6b6d2e495dac44dd0d5ee870edf6d8bacbcc8a5059d74c4b91d2bf5c9d6f')
+ '00-Makefile.patch'
+ 'doas-pam'
+ 'doas.conf')
+sha256sums=('037813a404bfe35289f2c6cb22a8c4de6f636b2a491e546a90d2ae2afa54aa64'
+ '600c7686b4c52bb28951e6e0815530d4bc8fec159637ad93d9b0757e750bcabd'
+ 'b064704fb3448c3511904c3963b0e167ecf6274aea48afb9c42d452447dfd042'
+ '1f28802fad6ae0eaa5b94bb8d945ada923631ddfb7ae63e934962dbe41774976')
prepare() {
cd "$pkgname-$pkgver"
- patch -Np1 -i "${srcdir}/$pkgname.patch"
+ patch -i "${srcdir}/00-Makefile.patch"
}
build() {
@@ -28,6 +32,7 @@ build() {
package() {
install -Dm644 "doas-pam" "$pkgdir/etc/pam.d/doas"
+ install -Dm644 "doas.conf" "$pkgdir/etc/doas.conf"
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"