summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago Perrotta2016-09-09 13:18:27 -0300
committerThiago Perrotta2016-09-09 13:20:25 -0300
commit5fda0c6d420a3542282363e4df8892fcee413788 (patch)
tree2e871927211418a1bdd4f5b198d99e094968236f /PKGBUILD
parent399a6f632824f585ffaf41419dcec3d09a749751 (diff)
downloadaur-5fda0c6d420a3542282363e4df8892fcee413788.tar.gz
bump to 1.1.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae0541f95c74..1863e197f270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=docfetcher
_name=DocFetcher
-pkgver=1.1.17
+pkgver=1.1.18
pkgrel=1
pkgdesc="A java open source desktop search application"
arch=('i686' 'x86_64')
@@ -14,14 +14,13 @@ source=("https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgve
'docfetcher'
'swt.patch'
'docfetcher.desktop')
-md5sums=('ed2bb1f6cc4b648955badff96459cf23'
+md5sums=('b039751b4359b4159e7183e26930ffd7'
'6a798b893868bf6b5e78093143654b39'
- '399d4f4294039f8142f32fd770d441d7'
- '363fdc2fa2e4e8f090fdc16b86939cb3')
+ '046e05ecfec4c0a2f6733c558317417f'
+ '363fdc2fa2e4e8f090fdc16b86939cb3')
prepare() {
cd "${srcdir}"
- #unzip -qqo "${pkgname}-${pkgver}-portable.zip"
# Patch to add where SWT libraries will be unpacked. See the following link:
# http://docfetcher.sourceforge.net/wiki/doku.php?id=faq
@@ -39,18 +38,17 @@ package() {
install -Dm755 "../${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
# Remove files from other platforms and other unnecessary ones
- rm -r "${_name}.app"
+ # find . -name '*.app' -exec rm -r '{}' \;
find . -name '*.exe' -exec rm -r '{}' \;
+ find . -name '*.bat' -exec rm -r '{}' \;
rm "Readme.txt"
# Copy files to destination
prefix="${pkgdir}/usr/share/${pkgname}"
install -d "${prefix}"
- for file in *
- do
+ for file in *; do
cp -a "${file}" "${prefix}/${file}"
done
find "${prefix}" -type d -exec chmod 0755 {} \;
find "${prefix}" -type f -exec chmod 0644 {} \;
- chmod +x "${prefix}/${_name}.sh"
}