summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Birks2020-04-24 08:21:02 -0400
committerDavid Birks2020-04-24 08:21:02 -0400
commit9698243b1f4497dbea6e52c07d94aecf401124fd (patch)
tree461287915eec284b1539385f7c557951b4b426c0 /PKGBUILD
parent82f3edaf317a526d33ec4fec59e44fb8a2b454d8 (diff)
downloadaur-docker-app.tar.gz
Update to 0.9.1-beta3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 540f4f35ee32..7b4dfd7edec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: David Birks <david@tellus.space>
+# Maintainer: David Birks <david@birks.dev>
pkgname=docker-app
-pkgver=0.8.0
+pkgver=0.9.1_beta3
pkgrel=1
epoch=1
pkgdesc='A utility to help make Compose files more reusable and sharable'
@@ -10,12 +10,12 @@ url='https://github.com/docker/app'
license=(Apache)
depends=('docker')
makedepends=('go')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/docker/app/archive/v$pkgver.tar.gz")
-sha512sums=('e1dc60e1d98167531067ffc01472e646f2262c696535b9379d59ae9805840e739624b400ae2152dfce87dc994997d03e0f5be9745b385dd4e0e67a957e733788')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/docker/app/archive/v${pkgver/_/-}.tar.gz")
+sha512sums=('42216f1b585d8bc2caf9cfe3b644edbc3838f0c16daa00da0047115cd9b8fbd9a22155951a101f7f40a2335ddc651297a452dfbb94ba12be02e1fbaa75b559b1')
prepare() {
mkdir -p gopath/src/github.com/docker
- ln -rTsf app-$pkgver gopath/src/github.com/docker/app
+ ln -rTsf app-${pkgver/_/-} gopath/src/github.com/docker/app
}
build() {
@@ -24,11 +24,11 @@ build() {
export GOPATH="$srcdir"/gopath
cd gopath/src/github.com/docker/app
- make bin/docker-app-standalone
+ make bin/docker-app
}
package() {
- install -Dm 755 "$srcdir/gopath/src/github.com/docker/app/bin/$pkgname-standalone" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 755 "$srcdir/gopath/src/github.com/docker/app/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
# Add command completion
install -dm 755 "$pkgdir/usr/share/bash-completion/completions"