summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Birks2019-04-30 14:30:00 -0400
committerDavid Birks2019-04-30 14:30:00 -0400
commit2d7f91e471c89985d553f760ec8f733a30e3371e (patch)
treebd63bca96a94ce74ed688d9adb0088cd9cb2f5cc /PKGBUILD
parentacbaadc7c61fba9811ab25a55d42f5380f870dc7 (diff)
downloadaur-2d7f91e471c89985d553f760ec8f733a30e3371e.tar.gz
Add command completion for bash and zsh
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60a50ad15eda..cdbaca9eb519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,4 +28,10 @@ build() {
package() {
install -Dm 755 "$srcdir/gopath/src/github.com/docker/app/bin/$pkgname-standalone" "$pkgdir/usr/bin/$pkgname"
+
+ # Add command completion
+ install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
+ install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
+ "$pkgdir/usr/bin/docker-app" completion bash > "$pkgdir/usr/share/bash-completion/completions/docker-app"
+ "$pkgdir/usr/bin/docker-app" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_docker-app"
}