aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeptune2023-07-29 20:21:00 -0500
committerNeptune2023-07-29 20:21:00 -0500
commit71ea82d151604fbdc353bc42e9c00e2c2be3ac1e (patch)
tree7384b55dcd1e1a251c63cda621785682e7481414 /PKGBUILD
parentd6adcc8353a33b3bf3d6f2347d648902e638b406 (diff)
downloadaur-docker-git.tar.gz
Fix build and bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caa72f7b0603..f0492a46e602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgname=docker-git
_pkgname=docker
-pkgver=r39078.b5ea9abf25
+pkgver=r46893.a908460adb
pkgrel=1
epoch=1
pkgdesc='Pack, ship and run any application as a lightweight container.'
@@ -36,13 +36,13 @@ source=('moby::git+https://github.com/moby/moby.git'
'libnetwork::git+https://github.com/docker/libnetwork.git'
'tini::git+https://github.com/krallin/tini.git'
'docker.install')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '1a8e60447794b3c4f87a2272cc9f144f')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e9c4e8ffb92f0464a5cad4fb1a1e2a3925667ba6703dd0e5b3efc0dca6f5fcad')
pkgver() {
pushd "$srcdir/moby" > /dev/null
@@ -99,6 +99,7 @@ build() {
ln -sf "$srcdir/libnetwork" "$GOPATH/src/github.com/docker/"
pushd "$GOPATH/src/github.com/docker/libnetwork" >/dev/null
: "${PROXY_LDFLAGS:=-linkmode=external}"
+ export AUTO_GOPATH=1
go build -ldflags="$PROXY_LDFLAGS" -o ./bin/docker-proxy 'github.com/docker/libnetwork/cmd/proxy'
popd >/dev/null