summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-24 15:02:09 +0200
committerDimitris Kiziridis2020-03-24 15:02:09 +0200
commitc2de7a061e03c206e041f7650fec5bc51e591f94 (patch)
treea2f4d79250a2303daa26c63adfe62821ed24b446 /PKGBUILD
downloadaur-c2de7a061e03c206e041f7650fec5bc51e591f94.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65006e258a6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=dockly
+pkgver=3.14.4
+pkgrel=1
+pkgdesc="Immersive terminal interface for managing docker containers and services"
+arch=('any')
+url='https://lirantal.github.io/dockly/'
+license=('MIT')
+makedepends=('npm')
+noextract=("v${pkgver}.tar.gz")
+source=("https://github.com/lirantal/dockly/archive/v${pkgver}.tar.gz")
+md5sums=('636718b622aecfda5fe126ae96e8cc63')
+
+package() {
+ npm install -g --user root --prefix "${pkgdir}/usr" "${srcdir}/v${pkgver}.tar.gz"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+ local tmppackage="$(mktemp)"
+ local pkgjson="$pkgdir/usr/lib/node_modules/$pkgname/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
+ mv "$tmppackage" "$pkgjson"
+ chmod 644 "$pkgjson"
+ chown -R root:root "${pkgdir}"
+} \ No newline at end of file