summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYaohan Chen2018-03-08 23:57:22 -0500
committerYaohan Chen2018-03-08 23:58:41 -0500
commit3e98ccffdd3e31964b77acb74a22447ac58af8a2 (patch)
treeabd1446a2ef0ee411b5bdbf011bbe7ff526b6d6f /PKGBUILD
parenteaffaca8b29684652ed22505afd99a8af8ede7d5 (diff)
downloadaur-3e98ccffdd3e31964b77acb74a22447ac58af8a2.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD93
1 files changed, 56 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5cb8d4b1ec0..b0a073f747ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,58 +3,77 @@
# Contributor: p2k <Patrick.Schneider@uni-ulm.de>
# Contributor: Schtroumpfette <fpeterschmitt@voila.fr>
+# 1: use adl to launch the game. Otherwise, use official game binaries directly.
+USE_ADL=1
+
pkgname=dofus-beta
-pkgver=2.21
-pkgrel=2
-pkgdesc='A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR (Beta version).'
+pkgver=2.46
+pkgrel=1
+pkgdesc='A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR (Beta version).'
arch=('i686' 'x86_64')
url='http://www.dofus.com/'
license=('custom:Dofus License')
install='dofus-beta.install'
-backup=('opt/ankama/dofus-beta/transition.conf')
-depends=('ankama-transition>=3.8.1-3' 'adobe-air-sdk')
-depends_i686=('gtk2' 'alsa-lib')
-depends_x86_64=('lib32-gtk2' 'lib32-alsa-lib')
+depends=('adobe-air-sdk' 'qt5-base' 'libpng12')
+depends_x86_64+=('lib32-gtk2' 'lib32-alsa-lib' 'lib32-alsa-plugins')
+depends_i686+=('gtk2' 'alsa-lib' 'alsa-plugins')
+optdepends=('pulseaudio-alsa: Required for the game to play sounds with PulseAudio')
-source=('dofus-beta.sh'
- 'dofus-beta.desktop'
+source=('dofus-beta.desktop'
+ 'dofus-beta.sh'
'air-generic-launcher.sh'
- 'transition.conf')
-source_i686=('http://dl.ak.ankama.com/games/dofus2-beta/setup/setup-beta-transition-x86.tar.gz')
-source_x86_64=('http://dl.ak.ankama.com/games/dofus2-beta/setup/setup-beta-transition-amd64.tar.gz')
+ 'transition.conf.patch')
+source_i686=('http://dl.ak.ankama.com/games/installers/beta/dofus-beta-x86.tar.gz')
+source_x86_64=('http://dl.ak.ankama.com/games/installers/beta/dofus-beta-amd64.tar.gz')
+md5sums=('0e797e4fcf39e1d06f68b51bfd215040'
+ 'cecd52aa9a58f756fa15925528400d66'
+ '092f6852a6ea603a7b8c7175a13eb416'
+ '28fa5927aad634debf7f1ff9f549f59c')
+md5sums_i686=('01ce4e20df355f9a5724ef5c5b880cbf')
+md5sums_x86_64=('7566e58290a158e12156ef8ab608c7d0')
-md5sums=('91023d67a519421912b3d101ded7ca12'
- '0e797e4fcf39e1d06f68b51bfd215040'
- 'f179eaa5e6e6674b1853cf826fc33c3a'
- 'fa976733b3be4df63e157ee6c3dd1186')
-md5sums_i686=('7dac81b01102aeafc0664e0e5e1d7106')
-md5sums_x86_64=('2daef0db4643b34688ba67793412f07b')
+prepare() {
+ if [ "$USE_ADL" -eq "1" ]
+ then
+ cd "$srcdir"
+ msg2 'Modifying transition configuration to use adl-based launchers'
+ patch -p0 < transition.conf.patch
+ fi
+}
package() {
- _installdir="$pkgdir/opt/ankama/dofus-beta"
- install -d "$_installdir"
-
- cd "$srcdir"
- msg2 'Installing menu entry...'
- install -Dm755 'dofus-beta.sh' "$pkgdir/usr/bin/dofus-beta"
- install -Dm644 'dofus-beta.desktop' "$pkgdir/usr/share/applications/dofus-beta.desktop"
- install -Dm644 'DofusBeta/share/icon/dofus-icon-128.png' "$pkgdir/usr/share/pixmaps/dofus-beta.png"
-
msg2 'Installing main applications...'
- mv "DofusBeta/"{bin,share} "$_installdir"
- install -Dm644 transition.conf "$_installdir"
+ installdir='opt/ankama/dofus-beta'
+ install -d "$pkgdir/$installdir"
+ cp -r "$srcdir/DofusBeta/"* "$pkgdir/$installdir"
msg2 'Setting up game file permissions...'
- chgrp -R games $_installdir
- chmod -R g+w $_installdir
- chmod 666 "$_installdir/share/META-INF/AIR/application.xml"
+ chgrp -R games "$pkgdir/$installdir"
+ chmod -R g+w "$pkgdir/$installdir"
+ install -dm775 "$pkgdir/$installdir/bin"
+ install -dm775 "$pkgdir/$installdir/share/reg/"
+ install -dm775 "$pkgdir/$installdir/share/reg/bin"
+
+ msg2 'Installing launcher...'
+ install -Dm755 "$srcdir/dofus-beta.sh" "$pkgdir/usr/bin/dofus-beta"
+ install -Dm644 "$srcdir/dofus-beta.desktop" "$pkgdir/usr/share/applications/dofus-beta.desktop"
- msg2 'Installing adl based launchers...'
- install -Dm755 'air-generic-launcher.sh' "$_installdir/bin"
- install -Dm755 'air-generic-launcher.sh' "$_installdir/share/reg/bin"
+ msg2 'Installing icons...'
+ for icon in "$srcdir/DofusBeta/share/updater_data/icons/game_icon_"*'.png'
+ do
+ size="$(basename "$icon" | grep -o '[0-9]\+x[0-9]\+')"
+ install -Dm644 "$icon" "$pkgdir/usr/share/icons/hicolor/$size/apps/dofus-beta.png"
+ done
- msg2 'Installing transition update file...'
- ln -s '/opt/ankama/transition/' "$_installdir/transition"
+ if [ "$USE_ADL" -eq "1" ]
+ then
+ msg2 'Installing adl based launchers...'
+ install -Dm755 'air-generic-launcher.sh' "$pkgdir/$installdir/bin/air-generic-launcher.sh"
+ install -Dm755 'air-generic-launcher.sh' "$pkgdir/$installdir/share/reg/bin/air-generic-launcher.sh"
+ else
+ msg2 'Installing link to bypass Adobe Air detection...'
+ ln -s '/opt/adobe-air-sdk/runtimes/air/linux/Adobe AIR/' "$pkgdir/opt/Adobe AIR"
+ fi
}
# vim:set ts=2 sw=2 et: