summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-11-08 03:07:28 +0300
committerorhun2020-11-08 03:07:28 +0300
commit9fad3688579d44e67dc0eeeed09a126f2c26784a (patch)
tree59e2720dec2fa6412297b4483b8aef431baf05b3 /PKGBUILD
downloadaur-9fad3688579d44e67dc0eeeed09a126f2c26784a.tar.gz
Initial upload: dog-dns 0.1.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f78438c9e1ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=dog-dns
+_pkgname=dog
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Command-line DNS client"
+arch=('x86_64')
+url="https://github.com/ogham/dog"
+license=('custom:EUPL')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('03af5414b995710d22ea19bdbf382def4e53ae2870f396b4103546743c9cafcc445ee0819b6c8b7f435793fead5ebd03f091be89293a32847868a5544b4bc0e5')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -Dm 755 "target/release/$_pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+ install -Dm 644 LICENCE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm 644 "completions/$_pkgname.bash" "${pkgdir}/usr/share/bash-completion/completions/$_pkgname"
+ install -Dm 644 "completions/$_pkgname.fish" -t "${pkgdir}/usr/share/fish/completions"
+ install -Dm 644 "completions/$_pkgname.zsh" "${pkgdir}/usr/share/zsh/functions/Completion/Linux/_$_pkgname"
+}