summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDylan2018-04-02 11:09:32 -0400
committerDylan2018-04-02 11:09:32 -0400
commit4f5085abf397319e1595fbad1aab396908c3f13e (patch)
tree5fb5b0a4d38164374a84cc248b04e914de6508ba /PKGBUILD
parenta497db5c3fd8ad861a621f15670ee8ffb8c73468 (diff)
downloadaur-4f5085abf397319e1595fbad1aab396908c3f13e.tar.gz
Update to 1.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbbc618d159b..9dc7f8634637 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Dylan <dylan@hashflo.net>
+# Maintainer: Dylan <dylan@psilly.com>
pkg_base=dogecoin
pkgname=('dogecoin-daemon')
-pkgver=1.10.0
-_git_branch=master
-pkgrel=4
+pkgver=1.14.0.2
+_full_pkgver='1.14-alpha-2'
+pkgrel=1
arch=('i686' 'x86_64')
url='http://dogecoin.com/'
makedepends=('boost' 'automoc4' 'protobuf')
conflicts=('dogecoin-qt')
license=('MIT')
source=(
- https://github.com/$pkg_base/$pkg_base/archive/$_git_branch.tar.gz
+ https://github.com/$pkg_base/$pkg_base/archive/v$_full_pkgver.tar.gz
)
sha256sums=(
- '8dc2125a5e36fd20b471ab63a8db837566528b3a23079fdc24da8573d7d98d1a'
+ 'd76d6c9f42304aa617668da145a14aba858fedea69bfccebbdc6fe15c49b3b4d'
)
install=$pkgname.install
build() {
- cd $srcdir/$pkg_base-$_git_branch
+ cd $srcdir/$pkg_base-$_full_pkgver
./autogen.sh
./configure --enable-cxx --prefix=/usr --with-gui=no --disable-tests --without-miniupnpc --with-incompatible-bdb
make
@@ -27,8 +27,8 @@ build() {
package_dogecoin-daemon() {
pkgdesc='Dogecoin is a peer-to-peer network based digital currency - daemon'
- depends=(boost-libs openssl)
- cd $srcdir/$pkg_base-$_git_branch
+ depends=('boost-libs' 'libressl')
+ cd $srcdir/$pkg_base-$_full_pkgver
install -Dm755 src/$pkg_base'd' $pkgdir/usr/bin/$pkg_base'd'
install -Dm755 src/$pkg_base'-cli' $pkgdir/usr/bin/$pkg_base'-cli'
install -Dm644 contrib/debian/examples/$pkg_base.conf $pkgdir/usr/share/doc/$pkgname/examples/$pkg_base.conf