summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authord1ceward2020-12-20 05:58:32 +0100
committerd1ceward2020-12-20 05:58:32 +0100
commitc807e15f290b9390bf4b7b879664336d102a6127 (patch)
tree48e017e374e5b88fd35a36c640784f59c1c64289 /PKGBUILD
parent3ed619385648c9ad945d2dd1933259427ecd795b (diff)
downloadaur-c807e15f290b9390bf4b7b879664336d102a6127.tar.gz
upgpkg: dokku 0.22.2-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 20 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22fe5997e355..24550f4d5c33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dokku
pkgver=0.22.2
-pkgrel=1
+pkgrel=2
pkgdesc='Docker-powered PaaS that helps build and manage the lifecycle of applications'
arch=('any')
url='https://github.com/dokku/dokku'
@@ -23,48 +23,40 @@ depends=(
'rsyslog'
'sshcommand'
)
-source=("https://github.com/dokku/dokku/archive/v${pkgver}.zip"
- "${pkgname}.install"
+source=("https://github.com/dokku/dokku/archive/v$pkgver.zip"
+ "$pkgname.install"
"LICENSE")
sha256sums=('2e8027b79828988ab58ab3cdbfd1fa9259fb5f1fb1db42f456bddcf6d7f305ee'
'd6887859d5c43febf6591c32d8b4706797a28ce308050b62871bc3f7f9df418e'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
-install="${pkgname}.install"
+install="$pkgname.install"
-prepare() {
- # Setup go directory
- mkdir -p gopath/src/github.com/dokku
- ln -rTsf "${srcdir}/${pkgname}-${pkgver}" "gopath/src/github.com/dokku/${pkgname}"
- export GOPATH="${srcdir}/gopath"
+build() {
+ export GOPATH="$srcdir/gopath"
- # Get go dependencies
- go get github.com/ryanuber/columnize
-}
-
-package() {
- export GOPATH="${srcdir}/gopath"
-
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- # Install executable and license
- install -Dm755 dokku "${pkgdir}/usr/bin/dokku"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/dokku/LICENSE"
+ cd "$pkgname-$pkgver"
# Add .core and build go plugins
for plugin in plugins/*; do
- if [ -e "${plugin}/Makefile" ]; then make -C "${plugin}" build; fi
- touch .core
+ if [ -e "$plugin/Makefile" ]; then make -C $plugin build; fi
+ touch "$plugin/.core"
done
# Clean go plugins
for plugin in plugins/*; do
- if [ -e "${plugin}/Makefile" ]; then make -C "${plugin}" src-clean; fi
+ if [ -e "$plugin/Makefile" ]; then make -C $plugin src-clean; fi
done
+}
+
+package() {
+ # Install executable and license
+ install -Dm755 "$pkgname-$pkgver/dokku" "$pkgdir/usr/bin/dokku"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/dokku/LICENSE"
# Move all files in place
- mkdir -p "${pkgdir}/var/lib/dokku/core-plugins/available"
- cp -R plugins/* "${pkgdir}/var/lib/dokku/core-plugins/available"
+ mkdir -p "$pkgdir/var/lib/dokku/core-plugins/available"
+ cp -R "$srcdir/$pkgname-$pkgver/plugins/." "$pkgdir/var/lib/dokku/core-plugins/available"
- # Version
- echo $pkgver > "${pkgdir}/var/lib/dokku/VERSION"
+ # Version
+ echo $pkgver > "$pkgdir/var/lib/dokku/VERSION"
}