summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Hornich2020-07-20 19:44:23 +0200
committerJulian Hornich2020-07-20 19:44:23 +0200
commit45ff0668464fb30354caf9870ebce10370e0aba2 (patch)
treef0756a2ca4cdc4ca3aec6929875d3cb18421b27b /PKGBUILD
parent802cf43bed923fc9fa9231ebd4475f7efa9b3543 (diff)
downloadaur-45ff0668464fb30354caf9870ebce10370e0aba2.tar.gz
update to dolfin 0.9.1-hpc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1339bbf3cf9a..2f67c66dc2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Julian Hornich <hornich at kth dot se>
pkgname=dolfin-hpc
-pkgver=0.9.0_hpc_20200205
+pkgver=0.9.1_hpc_20200720
pkgrel=1
pkgdesc="DOLFIN HPC is a special branch of DOLFIN optimized for distributed memory architectures"
-_tag=0.9.0-hpc
+_tag=0.9.1-hpc
arch=('i686' 'x86_64')
url="https://bitbucket.org/adaptivesimulations/dolfin-hpc/"
license=('LGPL')
groups=('dolfin-hpc-git')
-depends=('python2' 'ffc-hpc-git' 'libxml2' 'petsc' 'parmetis' 'gts' 'openmpi')
+depends=('python' 'ffc-hpc-git' 'petsc' 'parmetis' 'gts' 'openmpi' 'parallel-hashmap-git')
optdepends=()
makedepends=('git' 'python' 'sed' 'gcc')
provides=('dolfin')
@@ -25,9 +25,10 @@ pkgver() {
prepare() {
cd dolfin-hpc
sh regen.sh
- ./configure --prefix=${pkgdir}/opt/dolfin PYTHON=python2 CXXFLAGS="-O3 -march=native -std=c++14" \
- --with-petsc=/opt/petsc/linux-c-opt --with-gts --with-xml --enable-python --with-parmetis \
- --enable-quadrature --enable-mpi --enable-mpi-io
+ ./configure --prefix=${pkgdir}/opt/dolfin PYTHON=python3 CXXFLAGS="-O3 -march=native -std=c++14" \
+ --with-petsc=/opt/petsc/linux-c-opt --with-gts --enable-python --with-parmetis \
+ --enable-quadrature --enable-mpi --enable-mpi-io --with-phmap --enable-function-cache \
+ --enable-optimize-p1 --enable-opt-basis
}
build() {