summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Hornich2020-02-07 14:23:13 +0100
committerJulian Hornich2020-02-07 14:23:13 +0100
commit802cf43bed923fc9fa9231ebd4475f7efa9b3543 (patch)
tree4388e5ec139da33345f87e37c6b8bb0d99d7d604 /PKGBUILD
downloadaur-802cf43bed923fc9fa9231ebd4475f7efa9b3543.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1339bbf3cf9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Julian Hornich <hornich at kth dot se>
+pkgname=dolfin-hpc
+pkgver=0.9.0_hpc_20200205
+pkgrel=1
+pkgdesc="DOLFIN HPC is a special branch of DOLFIN optimized for distributed memory architectures"
+_tag=0.9.0-hpc
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/adaptivesimulations/dolfin-hpc/"
+license=('LGPL')
+groups=('dolfin-hpc-git')
+depends=('python2' 'ffc-hpc-git' 'libxml2' 'petsc' 'parmetis' 'gts' 'openmpi')
+optdepends=()
+makedepends=('git' 'python' 'sed' 'gcc')
+provides=('dolfin')
+conflicts=('dolfin')
+options=(!emptydirs)
+source=("dolfin-hpc::git+https://bitbucket.org/adaptivesimulations/dolfin-hpc.git#tag=${_tag}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd dolfin-hpc
+ echo "${_tag}_$(git log --format="%cd" --date=short -1 | sed 's/-//g')" | sed 's/-/_/g'
+}
+
+prepare() {
+ cd dolfin-hpc
+ sh regen.sh
+ ./configure --prefix=${pkgdir}/opt/dolfin PYTHON=python2 CXXFLAGS="-O3 -march=native -std=c++14" \
+ --with-petsc=/opt/petsc/linux-c-opt --with-gts --with-xml --enable-python --with-parmetis \
+ --enable-quadrature --enable-mpi --enable-mpi-io
+}
+
+build() {
+ cd dolfin-hpc
+ make ${MAKEFLAGS}
+}
+
+package() {
+ cd dolfin-hpc
+ make install
+}