summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpyamsoft2016-11-23 15:12:34 -0800
committerpyamsoft2016-11-23 15:12:34 -0800
commit661c10521a7c862ff3c7a566188253f6361d92b1 (patch)
tree2ae5504c61a90529d534687e454eec10d352b27e /PKGBUILD
parentceae7f5ecd8b198cbdbe753f9bd3ded61def7527 (diff)
downloadaur-661c10521a7c862ff3c7a566188253f6361d92b1.tar.gz
Add provides and conflicts for packages
Dolphin is unfortunately a bit inflexible at the moment (I also just don't understand CMake that well to modify paths and such) so unfortunately, multiple versions of dolphin-emu cannot be installed at the same time Sorry. Perhaps in the future this will be a thing.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1570fdabb7af..e21cdc9fc230 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,14 @@ sha256sums=('SKIP'
'62abf45f5064fac79aeead6340120be5beb8ad7a64f25fd85c07b45e3756df3f'
'a2ab0e1b737ff8af5a0ccacc40147d331ba0abe5e19aac019add68e732289605')
+# shellcheck disable=SC2034
+provides=('dolphin-emu')
+
+# shellcheck disable=SC2034
+conflicts=('dolphin-emu' 'dolphin-emu-git')
+
build() {
+ # shellcheck disable=SC2154
cd "${srcdir}/${pkgname}" || {
msg "Failed to cd into ${srcdir}/${pkgname}"
return 1
@@ -70,6 +77,7 @@ package() {
return 1
}
+ # shellcheck disable=SC2154
make DESTDIR="${pkgdir}" install
install -Dm 644 ../Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/