summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2023-01-25 12:02:10 +0100
committerDaniel Peukert2023-01-25 12:02:10 +0100
commit0013fcae7c81297510e0600dc154abf1e62c0bdc (patch)
tree20c5f665ecb039772d135278f4b255a6156dd968 /PKGBUILD
parentab55f9035571e2da7a1411d2653d95043b662e6b (diff)
downloadaur-0013fcae7c81297510e0600dc154abf1e62c0bdc.tar.gz
Add gtest git submodule to dolphin-emu-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a47ddb67614d..38001f1a69a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r18269.g1cd11b8f3a'
+pkgver='5.0.r18344.g6db2171fd0'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -29,12 +29,14 @@ source=(
"$pkgname-libspng::git+https://github.com/randy408/libspng.git"
"$pkgname-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git"
"$pkgname-implot::git+https://github.com/epezent/implot.git"
+ "$pkgname-gtest::git+https://github.com/google/googletest.git"
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
_sourcedirectory="$pkgname"
@@ -73,6 +75,12 @@ prepare() {
git submodule init "$_implotpath"
git config "submodule.$_implotpath.url" "$srcdir/$pkgname-implot/"
git -c protocol.file.allow=always submodule update "$_implotpath"
+
+ # Provide gtest submodule
+ _gtestpath='Externals/gtest'
+ git submodule init "$_gtestpath"
+ git config "submodule.$_gtestpath.url" "$srcdir/$pkgname-gtest/"
+ git -c protocol.file.allow=always submodule update "$_gtestpath"
}
pkgver() {