summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2023-12-24 17:06:26 +0100
committerDaniel Peukert2023-12-24 17:06:26 +0100
commit3830eacf73c4edcb531f033f5c343f25e87bf83d (patch)
tree24f32f49d178a5bc1c49fd7825761976f9fc1eb2 /PKGBUILD
parent051ab319a94d046aa896ac3e546ec8be654cfe17 (diff)
downloadaur-3830eacf73c4edcb531f033f5c343f25e87bf83d.tar.gz
Fix dolphin-emu-git enet dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 540fbbee0ddd..c999c52f0adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _noguipkgname="$_projectname-emu-nogui"
_toolpkgname="$_projectname-emu-tool"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git" "$_toolpkgname-git")
-pkgver='5.0.r20580.gdd227fea5a'
+pkgver='5.0.r20840.g57327be7f3'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -16,9 +16,9 @@ arch=('x86_64' 'aarch64')
url="https://$_mainpkgname.org"
license=('GPL2')
depends=(
- 'alsa-lib' 'bluez-libs' 'bzip2' 'enet' 'hidapi' 'libevdev' 'libgl' 'libpulse'
- 'libx11' 'libxi' 'libxrandr' 'lzo' 'mbedtls2' 'minizip-ng' 'pugixml' 'sfml'
- 'speexdsp' 'xz' 'zstd' 'cubeb' 'zlib-ng'
+ 'alsa-lib' 'bluez-libs' 'bzip2' 'hidapi' 'libevdev' 'libgl' 'libpulse' 'libx11'
+ 'libxi' 'libxrandr' 'lzo' 'mbedtls2' 'minizip-ng' 'pugixml' 'sfml' 'speexdsp'
+ 'xz' 'zstd' 'cubeb' 'zlib-ng'
'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libcurl.so' 'libfmt.so'
'libsfml-network.so' 'libsfml-system.so' 'libspng.so' 'libswscale.so'
'libudev.so' 'libusb-1.0.so' 'libxxhash.so'
@@ -28,6 +28,7 @@ optdepends=('pulseaudio: PulseAudio backend')
options=('!lto')
source=(
"$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
+ "$pkgname-enet::git+https://github.com/lsalzman/enet.git"
"$pkgname-implot::git+https://github.com/epezent/implot.git"
"$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
"$pkgname-rcheevos::git+https://github.com/RetroAchievements/rcheevos.git"
@@ -39,6 +40,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e')
_sourcedirectory="$pkgname"
@@ -53,6 +55,7 @@ prepare() {
# Provide submodules
declare -A _submodules=(
+ [enet]='enet/enet'
[implot]='implot/implot'
[mgba]='mGBA/mgba'
[rcheevos]='rcheevos/rcheevos'