summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2022-07-15 00:38:14 +0200
committerDaniel Peukert2022-07-15 00:38:14 +0200
commit3f1e0d435e804f8cdc0785b5e5610a4949b7a20b (patch)
tree67b1756ec6567fb98baebd22773e93dac17937f5 /PKGBUILD
parent17106c0cd609377807163bb66526a24795e5394e (diff)
downloadaur-3f1e0d435e804f8cdc0785b5e5610a4949b7a20b.tar.gz
Add missing SPIRV-Cross submodule to dolphin-emu-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b64089f0c851..76b3c514e486 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r16541.gbb2a3d35b0'
+pkgver='5.0.r16907.g537fe33997'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -25,8 +25,10 @@ optdepends=('pulseaudio: PulseAudio backend')
source=(
"$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
"$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
+ "$pkgname-spirvcross::git+https://github.com/KhronosGroup/SPIRV-Cross.git"
)
sha512sums=('SKIP'
+ 'SKIP'
'SKIP')
_sourcedirectory="$pkgname"
@@ -37,10 +39,16 @@ prepare() {
mkdir 'build/'
# Provide mgba submodule
- _mgbapath="Externals/mGBA/mgba"
+ _mgbapath='Externals/mGBA/mgba'
git submodule init "$_mgbapath"
git config "submodule.$_mgbapath.url" "$srcdir/$pkgname-mgba/"
git submodule update "$_mgbapath"
+
+ # Provide SPIRV-Cross submodule
+ _spirvcrosspath='Externals/spirv_cross/SPIRV-Cross'
+ git submodule init "$_spirvcrosspath"
+ git config "submodule.$_spirvcrosspath.url" "$srcdir/$pkgname-spirvcross/"
+ git submodule update "$_spirvcrosspath"
}
pkgver() {