summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2023-07-29 20:44:47 +0200
committerDaniel Peukert2023-07-29 20:44:47 +0200
commite6c8d0c4271718051b58a0b57e661a46f736e321 (patch)
tree839dca0e82771fe67841c59a06d89d6a276c60f6 /PKGBUILD
parent9d1d45a8541e944feb282ad849f337c83dd9ba09 (diff)
downloadaur-e6c8d0c4271718051b58a0b57e661a46f736e321.tar.gz
Add dolphin-emu-git patch for fmt 10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2d8210f0669..f7b2dc91b3f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r19817.g3d9bc85912'
+pkgver='5.0.r19859.g30c4ac34b0'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -32,13 +32,15 @@ source=(
"$pkgname-rcheevos::git+https://github.com/RetroAchievements/rcheevos.git"
"$pkgname-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git"
'minizip-ng.diff'
+ 'fmt-10.diff'
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e')
+ '568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e'
+ '57852e07fc6e296598a3351a2ad63ac5af8c0130e1d1d8f0f8f99d0730fe01b1cf206e31efe1837a33ff2971e08fd48e281edc4be625c4660a711062812ae0ee')
_sourcedirectory="$pkgname"
@@ -50,6 +52,9 @@ prepare() {
# Fix minizip-ng name for Arch
patch --forward -p1 < "$srcdir/minizip-ng.diff"
+ # Fix build with fmt 10
+ patch --forward -p1 < "$srcdir/fmt-10.diff"
+
# Provide submodules
declare -A _submodules=(
[implot]='implot/implot'
@@ -73,7 +78,7 @@ pkgver() {
build() {
# CMAKE_BUILD_TYPE - the dolphin-emu package in the repos uses 'None' for some reason, so we use it as well
- # USE_SYSTEM_LIBS - we want to use systems libs where possible
+ # USE_SYSTEM_LIBS - we want to use system libs where possible
# USE_SYSTEM_LIBMGBA - the current version of mgba in the repos is not compatible with Dolphin
cd "$srcdir/$_sourcedirectory/"
cmake -S '.' -B 'build/' -G Ninja \