summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCpt_Huntsman2022-04-21 22:35:52 +0800
committerCpt_Huntsman2022-04-21 23:15:18 +0800
commit643797c324794dc9fef57d254b7eaa043ccc4dd9 (patch)
treec475bb579d39a077b057ab434fd191cac291051e /PKGBUILD
downloadaur-643797c324794dc9fef57d254b7eaa043ccc4dd9.tar.gz
Upload first PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5663f57f36b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Cpt_Huntsman <other.plan1133@fastmail.com>
+
+pkgname=dolphin-nospace
+_pkgname=dolphin
+pkgver=22.04.0
+pkgrel=1
+pkgdesc="KDE File Manager (with DuckSoft's Space Patch)"
+arch=(x86_64)
+url="https://kde.org/applications/system/dolphin/"
+license=(LGPL)
+provides=(dolphin)
+conflicts=(dolphin)
+depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kinit kactivities kuserfeedback)
+makedepends=(extra-cmake-modules kdoctools packagekit-qt5)
+optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video thumbnails' 'kdegraphics-thumbnailers: PDF and PS thumbnails'
+ 'konsole: terminal panel' 'purpose: share context menu' 'packagekit-qt5: service menu installer')
+source=("https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz"
+ "ducksoft-want-my-space-back.patch")
+sha256sums=('58c6cdd0d3b8ac41880e5ea2322cad92380c8c45336150c3c39f9357dfa4f100'
+ '21a50881ce6dce2a831d8fc0e2d1339a158aaabc65986bbe3c9e990a4a71fcbe')
+
+prepare() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ patch -p1 < ../ducksoft-want-my-space-back.patch
+}
+
+build() {
+ cmake -B build -S $_pkgname-$pkgver \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}