summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-07-31 16:36:01 +0200
committersl1pkn072015-07-31 16:36:01 +0200
commit064d132203271822117693165ffac6751b0670ca (patch)
treeefaa7cb4c8c54fa8a610614cd58f22dd9fcf051a /PKGBUILD
downloadaur-064d132203271822117693165ffac6751b0670ca.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af813a52a183
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=dolphin-plugins-git
+pkgver=r336.cef9dff
+pkgrel=1
+pkgdesc="Plugins for Dolphin. (GIT Version)"
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/kde/kdesdk/dolphin-plugins'
+license=('GPL' 'LGPL' 'FDL')
+depends=('dolphin-git')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
+conflicts=('dolphin-plugins' 'kdesdk-dolphin-plugins')
+source=('git://anongit.kde.org/dolphin-plugins')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd dolphin-plugins
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../dolphin-plugins \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}