summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2021-08-29 23:50:04 +0100
committerJoão Figueiredo2021-08-29 23:50:04 +0100
commit9c4429da6fba2721f703bfb45ac89bbdec760d68 (patch)
treeb839aad1f48914df3d0ce3ed0984022081e4d816 /PKGBUILD
parent064d132203271822117693165ffac6751b0670ca (diff)
downloadaur-9c4429da6fba2721f703bfb45ac89bbdec760d68.tar.gz
Merged with official ABS dolphin-plugins PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 24 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af813a52a183..5ba712ffe290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,37 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Merged with official ABS dolphin-plugins PKGBUILD by João, 2021/08/25 (all respective contributors apply herein)
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=dolphin-plugins-git
-pkgver=r336.cef9dff
+pkgver=21.11.70_r601.g04ae4bf
pkgrel=1
-pkgdesc="Plugins for Dolphin. (GIT Version)"
-arch=('i686' 'x86_64')
-url='https://projects.kde.org/projects/kde/kdesdk/dolphin-plugins'
-license=('GPL' 'LGPL' 'FDL')
-depends=('dolphin-git')
-makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
-conflicts=('dolphin-plugins' 'kdesdk-dolphin-plugins')
-source=('git://anongit.kde.org/dolphin-plugins')
-sha1sums=('SKIP')
+pkgdesc='Extra Dolphin plugins'
+arch=($CARCH)
+url='https://apps.kde.org/dolphin_plugins/'
+license=(LGPL)
+depends=(dolphin-git)
+makedepends=(git extra-cmake-modules-git ktexteditor-git)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+optdepends=('ktexteditor-git: Mercurial plugin')
+groups=(kde-applications-git kdesdk-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
- cd dolphin-plugins
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- mkdir -p build
+ cd ${pkgname%-git}
+ _major_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MAJOR' CMakeLists.txt | cut -d '"' -f2)"
+ _minor_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MINOR' CMakeLists.txt | cut -d '"' -f2)"
+ _micro_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MICRO' CMakeLists.txt | cut -d '"' -f2)"
+ echo "${_major_ver}.${_minor_ver}.${_micro_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd build
- cmake ../dolphin-plugins \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ cmake -B build -S ${pkgname%-git} \
-DBUILD_TESTING=OFF
- make
+ cmake --build build
}
package() {
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}