summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMelvin Vermeeren2018-01-07 18:15:31 +0100
committerMelvin Vermeeren2018-01-07 18:24:07 +0100
commit1b70c8f982fa5c421f2d4296411f4e49c791cc3a (patch)
tree3284675b81df85bed50a468b4c831dcd5631efa0 /PKGBUILD
parent93ed6809e912be2f57cf0e17dc823ffecf07391b (diff)
downloadaur-1b70c8f982fa5c421f2d4296411f4e49c791cc3a.tar.gz
disable all built-in, disable all static linking, style changes
(this also fixed openssl not being found since it tries to find static)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 27 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f534c2650f3c..1b1f0c0fabd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,50 @@
-# Maintainer: IanDury
+# Maintainer: Melvin Vermeeren <mail@mel.vin>
pkgname=domoticz-git
_gitname="domoticz"
-pkgver=r6749
+pkgver=r8799
pkgrel=1
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://www.domoticz.com"
license=('GPL')
-depends=('openzwave-git' 'libusb-compat' 'curl' 'sqlite' 'boost-libs')
+depends=('openzwave-git' 'libusb-compat' 'curl' 'sqlite' 'boost-libs' 'lua'
+ 'mosquitto' 'sqlite')
makedepends=('git' 'cmake' 'boost')
conflicts=('domoticz-svn')
install='domoticz-git.install'
source=('git+https://github.com/domoticz/domoticz.git'
- 'domoticz.service')
+ 'domoticz.service')
sha256sums=('SKIP'
- 'f45f382e5ae0d54f1b1f147b89f5ac5f62719c83a8eb280e20121f8dfc7b2697')
+ 'f45f382e5ae0d54f1b1f147b89f5ac5f62719c83a8eb280e20121f8dfc7b2697')
pkgver() {
- cd $_gitname
- printf "r%s" "$(git rev-list --count HEAD| awk '{print $1 + 2107}')"
+ cd "$_gitname"
+
+ printf 'r%s' "$(git rev-list --count HEAD| awk '{print $1 + 2107}')"
}
build() {
- cd $_gitname
- cmake -DCMAKE_BUILD_TYPE=Release -DUSE_STATIC_OPENZWAVE=NO CMakeLists.txt
+ cd "$_gitname"
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_BUILTIN_LUA=NO \
+ -DUSE_BUILTIN_MQTT=NO \
+ -DUSE_BUILTIN_SQLITE=NO \
+ -DUSE_OPENSSL_STATIC=NO \
+ -DUSE_STATIC_BOOST=NO \
+ -DUSE_STATIC_LIBSTDCXX=NO \
+ -DUSE_STATIC_OPENZWAVE=NO \
+ CMakeLists.txt
}
package() {
- cd $_gitname
+ cd "$_gitname"
- make DESTDIR=${pkgdir} install
- chmod o+r "${pkgdir}/opt/domoticz/updatedomo"
- mkdir -p "${pkgdir}/usr/lib/systemd/system"
- cp ../../domoticz.service "${pkgdir}/usr/lib/systemd/system/"
- chown -R http:http "${pkgdir}/opt/domoticz"
+ make DESTDIR="$pkgdir" install
+ chmod o+r "$pkgdir/opt/domoticz/updatedomo"
+ install -Dm 0644 "$srcdir/domoticz.service" \
+ "$pkgdir/usr/lib/systemd/system/domoticz.service"
+ chown -R http:http "$pkgdir/opt/domoticz"
}