summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-07-15 14:46:15 +0200
committerKlaus Alexander Seistrup2023-07-15 14:46:15 +0200
commit33db3e34ca96b657f8d59c91d59fea91f50d34f8 (patch)
treeb46c953de17341cbc181f1d51930cb1cb3ce1b75 /PKGBUILD
parentb9372faab3656d448a4b165249552fa18feaaa84 (diff)
downloadaur-33db3e34ca96b657f8d59c91d59fea91f50d34f8.tar.gz
Add missing dependencies
Also: * Remove libraries provided by upstream TODO: * Further dependency checking and library cleanup (for plugins) needed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD112
1 files changed, 88 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5919d114ceb..81e28ff0939b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,36 +5,100 @@
pkgname="dooble-bin"
pkgver=2023.07.15
-pkgrel=3
+pkgrel=4
pkgdesc="Web browser based on QtWebEngine"
arch=(x86_64)
url="https://textbrowser.github.io/dooble/"
_githuburl="https://github.com/textbrowser/${pkgname%-bin}"
license=('custom')
-depends=('dbus' 'gpgme' 'qt6-webengine' 'libglvnd' 'libxshmfence' 'libx11' 'gst-plugins-base-libs' 'bash' 'gdk-pixbuf2' 'libdrm' 'zlib' \
- 'libxkbfile' 'libassuan' 'glib2' 'expat' 'krb5' 'qt6-multimedia' 'at-spi2-core' 'libxcb' 'gtk3' 'libxi' 'libxdamage' 'libgpg-error' \
- 'sqlite' 'wayland' 'xcb-util-renderutil' 'fontconfig' 'qt6-positioning' 'libxrender' 'qt6-webchannel' 'freetype2' 'libxtst' 'nss' 'xcb-util-cursor' \
- 'unixodbc' 'libxfixes' 'glibc' 'libxkbcommon' 'libxrandr' 'qt6-base' 'pango' 'gcc-libs' 'qt6-declarative' 'alsa-lib' 'libxext' 'gstreamer' \
- 'xcb-util-image' 'libcups' 'xcb-util-keysyms' 'libxkbcommon-x11' 'xcb-util-wm' 'nspr' 'cairo' 'libxcomposite')
-makedepends=('findutils' 'gendesk')
+depends=(
+ 'alsa-lib'
+ 'at-spi2-core'
+ 'bash'
+ 'cairo'
+ 'dbus'
+ 'expat'
+ 'fontconfig'
+ 'freetype2'
+ 'gcc-libs'
+ 'gdk-pixbuf2'
+ 'glib2'
+ 'glibc'
+ 'gpgme'
+ 'gst-plugins-base-libs'
+ 'gstreamer'
+ 'gtk3'
+ 'krb5'
+ 'libassuan'
+ 'libcups'
+ 'libdrm'
+ 'libglvnd'
+ 'libgpg-error'
+ 'libx11'
+ 'libxcb'
+ 'libxcomposite'
+ 'libxdamage'
+ 'libxext'
+ 'libxfixes'
+ 'libxi'
+ 'libxkbcommon'
+ 'libxkbcommon-x11'
+ 'libxkbfile'
+ 'libxrandr'
+ 'libxrender'
+ 'libxshmfence'
+ 'libxtst'
+ 'nspr'
+ 'nss'
+ 'pango'
+ 'qt6-base'
+ 'qt6-charts'
+ 'qt6-declarative'
+ 'qt6-multimedia'
+ 'qt6-positioning'
+ 'qt6-svg'
+ 'qt6-webchannel'
+ 'qt6-webengine'
+ 'sqlite'
+ 'unixodbc'
+ 'wayland'
+ 'xcb-util-cursor'
+ 'xcb-util-image'
+ 'xcb-util-keysyms'
+ 'xcb-util-renderutil'
+ 'xcb-util-wm'
+ 'zlib'
+)
+makedepends=(
+ 'findutils'
+ 'gendesk'
+)
conflicts=("${pkgname%-bin}")
noextract=("${pkgname%-bin}-${pkgver}.tar.gz")
-source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/Dooble-${pkgver}.tar.gz"
- "LICENSE::https://raw.githubusercontent.com/textbrowser/dooble/master/LICENSE")
-sha256sums=('b02e95a85082bcc4c12fce1e547ebfacfe24c70a5e98140a15c570030023ecba'
- 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd')
+source=(
+ "${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/Dooble-${pkgver}.tar.gz"
+ "LICENSE::https://raw.githubusercontent.com/textbrowser/dooble/master/LICENSE"
+)
+sha256sums=(
+ 'b02e95a85082bcc4c12fce1e547ebfacfe24c70a5e98140a15c570030023ecba'
+ 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd'
+)
package() {
- install -Dm755 -d "${pkgdir}/opt"
- bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${pkgdir}/opt" --gname root --uname root
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "Dooble" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
- install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- # Fix incorrect permissions
- find "${pkgdir}" -type f -perm 0664 -print0 | xargs -r0 chmod 0644
- find "${pkgdir}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
- find "${pkgdir}" -type d -print0 | xargs -r0 chmod 0755
- # Add a symlink to dooble.sh for those who prefer to not use a mouse
- install -dm0755 "${pkgdir}/usr/bin"
- ln -sr "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/opt"
+ bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${pkgdir}/opt" --gname root --uname root
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "Dooble" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ # Fix incorrect permissions
+ find "${pkgdir}" -type f -perm 0664 -print0 | xargs -r0 chmod 0644
+ find "${pkgdir}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
+ find "${pkgdir}" -type d -print0 | xargs -r0 chmod 0755
+ # Add a symlink to dooble.sh for those who prefer to not use a mouse
+ install -dm0755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ # Remove libraries provided by upstream
+ rm -rf "${pkgdir}/opt/${pkgname%-bin}/Lib/"
}
+
+# eof