summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-07-14 06:32:52 +0200
committerKlaus Alexander Seistrup2023-07-14 06:32:52 +0200
commit3638da2f3d9bb59179a80d9b05d98762eefb64f6 (patch)
tree076251ab9988cbf019f81a12b654c09be1b1a2ec /PKGBUILD
parent4ef212cbc1863ba6aceabedb0c965b8d714d3970 (diff)
downloadaur-3638da2f3d9bb59179a80d9b05d98762eefb64f6.tar.gz
Fix all incorrect permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c77e91253d9f..11eaf40b0559 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
# Contributor: Balló György <ballogyor+arch at gmail dot com>
# Contributor: zhangkaizhao <zhangkaizhao at gmail dot com>
+# Contributor: Klaus Alexander Seistrup <klaus at seistrup dot dk>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+
pkgname="dooble-bin"
pkgver=2023.07.15
-pkgrel=1
+pkgrel=2
pkgdesc="Web browser based on QtWebEngine"
arch=(x86_64)
url="https://textbrowser.github.io/dooble/"
@@ -28,4 +30,8 @@ package() {
install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "Dooble" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
-} \ No newline at end of file
+ # Fix incorrect permissions
+ find "${pkgdir}" -type f -perm 0664 -print0 | xargs -r0 chmod 0644
+ find "${pkgdir}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
+ find "${pkgdir}" -type d -print0 | xargs -r0 chmod 0755
+}