summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-07-14 11:18:32 +0800
committerzxp198210052023-07-14 11:18:32 +0800
commit4ef212cbc1863ba6aceabedb0c965b8d714d3970 (patch)
tree185920df46f027a41f5034dfc26dcce9f1cb8e31 /PKGBUILD
parent5e672efacc2e4bf29651e7d18f91705433758145 (diff)
downloadaur-4ef212cbc1863ba6aceabedb0c965b8d714d3970.tar.gz
update to 2023.07.15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac95f8f4ae64..c77e91253d9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,30 @@
# Contributor: zhangkaizhao <zhangkaizhao at gmail dot com>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="dooble-bin"
-pkgver=2023.05.31
-pkgrel=3
+pkgver=2023.07.15
+pkgrel=1
pkgdesc="Web browser based on QtWebEngine"
arch=(x86_64)
url="https://textbrowser.github.io/dooble/"
_githuburl="https://github.com/textbrowser/${pkgname%-bin}"
license=('custom')
-depends=('libxshmfence' 'xcb-util-image' 'libxi' 'xcb-util-cursor' 'libxdamage' 'gstreamer' 'freetype2' 'libcups' 'libxcomposite' 'libx11' \
- 'qt6-declarative' 'gdk-pixbuf2' 'gcc-libs' 'glibc' 'nspr' 'gtk3' 'at-spi2-core' 'xcb-util-keysyms' 'bash' 'cairo' 'libdrm' \
- 'gst-plugins-base-libs' 'libxfixes' 'libglvnd' 'libxcb' 'fontconfig' 'libxkbcommon' 'xcb-util-wm' 'nss' 'alsa-lib' 'dbus' 'qt6-base' \
- 'krb5' 'libxkbcommon-x11' 'xcb-util-renderutil' 'glib2' 'libxrandr' 'libxrender' 'wayland' 'libxtst' 'expat' 'libxext' 'zlib' 'libxkbfile' 'pango')
-makedepends=('findutils')
+depends=('dbus' 'gpgme' 'qt6-webengine' 'libglvnd' 'libxshmfence' 'libx11' 'gst-plugins-base-libs' 'bash' 'gdk-pixbuf2' 'libdrm' 'zlib' \
+ 'libxkbfile' 'libassuan' 'glib2' 'expat' 'krb5' 'qt6-multimedia' 'at-spi2-core' 'libxcb' 'gtk3' 'libxi' 'libxdamage' 'libgpg-error' \
+ 'sqlite' 'wayland' 'xcb-util-renderutil' 'fontconfig' 'qt6-positioning' 'libxrender' 'qt6-webchannel' 'freetype2' 'libxtst' 'nss' 'xcb-util-cursor' \
+ 'unixodbc' 'libxfixes' 'glibc' 'libxkbcommon' 'libxrandr' 'qt6-base' 'pango' 'gcc-libs' 'qt6-declarative' 'alsa-lib' 'libxext' 'gstreamer' \
+ 'xcb-util-image' 'libcups' 'xcb-util-keysyms' 'libxkbcommon-x11' 'xcb-util-wm' 'nspr' 'cairo' 'libxcomposite')
+makedepends=('findutils' 'gendesk')
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/Dooble-${pkgver}_amd64.deb"
+noextract=("${pkgname%-bin}-${pkgver}.tar.gz")
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/Dooble-${pkgver}.tar.gz"
"LICENSE::https://raw.githubusercontent.com/textbrowser/dooble/master/LICENSE")
-sha256sums=('43c849dbef96a50685fedcdab8179b74bff0035233c13488af094220d50234f2'
+sha256sums=('b02e95a85082bcc4c12fce1e547ebfacfe24c70a5e98140a15c570030023ecba'
'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd')
package() {
- bsdtar -xf "${srcdir}/data.tar.zst" -C "${pkgdir}"
+ install -Dm755 -d "${pkgdir}/opt"
+ bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${pkgdir}/opt" --gname root --uname root
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- find "${pkgdir}" -type f -perm 0664 -print0 | xargs -r0 chmod 0644
- find "${pkgdir}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
- find "${pkgdir}" -type d -print0 | xargs -r0 chmod 0755
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "Dooble" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file