summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-05-30 17:25:26 +0800
committerzxp198210052023-05-30 17:25:26 +0800
commit5e672efacc2e4bf29651e7d18f91705433758145 (patch)
treeeae6bb223dd1394237579349b94a0d160186b677 /PKGBUILD
parent0489f06594f0e171b385469f7800721f7b5210da (diff)
downloadaur-5e672efacc2e4bf29651e7d18f91705433758145.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1613029e6ea2..ac95f8f4ae64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: zhangkaizhao <zhangkaizhao at gmail dot com>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="dooble-bin"
pkgver=2023.05.31
-pkgrel=2
+pkgrel=3
pkgdesc="Web browser based on QtWebEngine"
arch=(x86_64)
url="https://textbrowser.github.io/dooble/"
@@ -12,8 +13,8 @@ depends=('libxshmfence' 'xcb-util-image' 'libxi' 'xcb-util-cursor' 'libxdamage'
'qt6-declarative' 'gdk-pixbuf2' 'gcc-libs' 'glibc' 'nspr' 'gtk3' 'at-spi2-core' 'xcb-util-keysyms' 'bash' 'cairo' 'libdrm' \
'gst-plugins-base-libs' 'libxfixes' 'libglvnd' 'libxcb' 'fontconfig' 'libxkbcommon' 'xcb-util-wm' 'nss' 'alsa-lib' 'dbus' 'qt6-base' \
'krb5' 'libxkbcommon-x11' 'xcb-util-renderutil' 'glib2' 'libxrandr' 'libxrender' 'wayland' 'libxtst' 'expat' 'libxext' 'zlib' 'libxkbfile' 'pango')
+makedepends=('findutils')
conflicts=("${pkgname%-bin}")
-options=(!strip)
source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/Dooble-${pkgver}_amd64.deb"
"LICENSE::https://raw.githubusercontent.com/textbrowser/dooble/master/LICENSE")
sha256sums=('43c849dbef96a50685fedcdab8179b74bff0035233c13488af094220d50234f2'
@@ -21,6 +22,7 @@ sha256sums=('43c849dbef96a50685fedcdab8179b74bff0035233c13488af094220d50234f2'
package() {
bsdtar -xf "${srcdir}/data.tar.zst" -C "${pkgdir}"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} \;
- find "${pkgdir}/opt/${pkgname%-bin}" -name "*.*" -exec chmod 644 {} \;
+ find "${pkgdir}" -type f -perm 0664 -print0 | xargs -r0 chmod 0644
+ find "${pkgdir}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
+ find "${pkgdir}" -type d -print0 | xargs -r0 chmod 0755
} \ No newline at end of file