summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaizhao Zhang2021-08-20 03:13:58 +0800
committerKaizhao Zhang2021-08-20 03:15:20 +0800
commit66de0e12b6de341ea407af649f52b2d1528e24e4 (patch)
tree7c09ae91bf27fa6b2b04b015da590e04a17901b3 /PKGBUILD
downloadaur-66de0e12b6de341ea407af649f52b2d1528e24e4.tar.gz
Initial import with version 2021.08.05
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..926badc59178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_pkgname=dooble
+_repourl="https://github.com/textbrowser/dooble"
+
+pkgname=dooble-bin
+pkgver=2021.08.05
+pkgrel=1
+pkgdesc="Dooble is the scientific browser"
+arch=('x86_64')
+url="https://textbrowser.github.io/dooble/"
+license=('BSD')
+conflicts=('dooble')
+options=('!strip')
+depends=('alsa-lib' 'fontconfig' 'libgl' 'libxcomposite' 'libxkbcommon' 'libxrandr' 'nss')
+source=(
+ "https://github.com/textbrowser/dooble/releases/download/${pkgver}/Dooble-${pkgver}_amd64.deb"
+ "LICENSE-${pkgver}::${_repourl}/raw/${pkgver}/LICENSE"
+)
+noextract=("Dooble-${pkgver}_amd64.deb")
+sha256sums=(
+ 'afa11baecc2504ae63f9c8cd62c8a6bfbb994ff03db6e2cf0d9f2562b7163641'
+ 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd'
+)
+
+package() {
+ bsdtar -O -xf "Dooble-${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # Documentation
+ install -d "${pkgdir}/usr/share/doc"
+ ln -s "/opt/dooble/Documentation" "${pkgdir}/usr/share/doc/${_pkgname}"
+
+ # License
+ install -D -m644 "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}