summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-08-28 09:16:34 +0800
committerzxp198210052023-08-28 09:16:34 +0800
commitf18c254bd468cb309a32d0d80694f99874897364 (patch)
tree1e5beca35d0b7ca258b67b5e39db89b8540a580c /PKGBUILD
parente849ab522c3553945ede2314f43eaaf9f186a0fe (diff)
downloadaur-f18c254bd468cb309a32d0d80694f99874897364.tar.gz
update to 2023.08.30
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 27 insertions, 49 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccfdf58c34eb..842604c3a623 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,20 @@
+# Maintainer: Klaus Alexander Seistrup <klaus at seistrup dot dk>
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
# Contributor: Balló György <ballogyor+arch at gmail dot com>
# Contributor: zhangkaizhao <zhangkaizhao at gmail dot com>
-# Contributor: Klaus Alexander Seistrup <klaus at seistrup dot dk>
-# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-
-pkgname="dooble-bin"
-pkgver=2023.07.15
-pkgrel=5
+pkgname=dooble-bin
+_pkgname=Dooble
+pkgver=2023.08.30
+pkgrel=1
pkgdesc="Web browser based on QtWebEngine"
arch=(x86_64)
url="https://textbrowser.github.io/dooble/"
_githuburl="https://github.com/textbrowser/${pkgname%-bin}"
license=('custom')
depends=(
- #'alsa-lib'
'at-spi2-core'
'bash'
- 'bzip2'
'cairo'
- #'dbus'
- #'expat'
- #'fontconfig'
'freetype2'
'gcc-libs'
'gdk-pixbuf2'
@@ -29,28 +24,15 @@ depends=(
'gst-plugins-base-libs'
'gstreamer'
'gtk3'
- #'krb5'
- #'libassuan'
'libcups'
'libdrm'
'libglvnd'
- #'libgpg-error'
'libx11'
'libxcb'
- #'libxcomposite'
- #'libxdamage'
'libxext'
- #'libxfixes'
- #'libxi'
'libxkbcommon'
'libxkbcommon-x11'
- #'libxkbfile'
'libxrandr'
- #'libxrender'
- #'libxshmfence'
- #'libxtst'
- #'nspr'
- #'nss'
'pango'
'postgresql-libs'
'qt6-base'
@@ -64,7 +46,6 @@ depends=(
'qt6-wayland'
'qt6-webchannel'
'qt6-webengine'
- #'sqlite'
'unixodbc'
'wayland'
'xcb-util-cursor'
@@ -78,33 +59,30 @@ makedepends=(
'findutils'
'gendesk'
)
+provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-noextract=("${pkgname%-bin}-${pkgver}.tar.gz")
source=(
"${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/Dooble-${pkgver}.tar.gz"
"LICENSE::https://raw.githubusercontent.com/textbrowser/dooble/master/LICENSE"
)
-sha256sums=(
- 'b02e95a85082bcc4c12fce1e547ebfacfe24c70a5e98140a15c570030023ecba'
- 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd'
-)
-package() {
- install -Dm755 -d "${pkgdir}/opt"
- bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${pkgdir}/opt" --gname root --uname root
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "Dooble" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
- install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- # Fix incorrect permissions
- find "${pkgdir}" -type d -print0 | xargs -r0 chmod 0755
- find "${pkgdir}" -type f -perm 0664 -print0 | xargs -r0 chmod 0644
- find "${pkgdir}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
- find "${pkgdir}" -type f -name '*.so' -print0 | xargs -r0 chmod 0755
- # Add a symlink to dooble.sh for those who prefer to not use a mouse
- install -dm0755 "${pkgdir}/usr/bin"
- ln -sr "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- # Remove libraries provided by upstream
- rm -rf "${pkgdir}/opt/${pkgname%-bin}/Lib/"
+sha256sums=('407057d48fa3aaf78c378c9b8e9ad8181cf0ee25eb5dbe75801e133718a9d34c'
+ 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd')
+prepare() {
+ gendesk -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin}"
}
-
-# eof
+package() {
+ install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
+ cp -r "${srcdir}/${pkgname%-bin}" "${pkgdir}/opt"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ # Fix incorrect permissions
+ find "${pkgdir}" -type d -print0 | xargs -r0 chmod 0755
+ find "${pkgdir}" -type f -perm 0664 -print0 | xargs -r0 chmod 0644
+ find "${pkgdir}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
+ find "${pkgdir}" -type f -name '*.so' -print0 | xargs -r0 chmod 0755
+ # Add a symlink to dooble.sh for those who prefer to not use a mouse
+ ln -sr "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ # Remove libraries provided by upstream
+ rm -rf "${pkgdir}/opt/${pkgname%-bin}/Lib/"
+} \ No newline at end of file