summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPol Marcet Sardà2023-02-12 11:38:54 +0100
committerPol Marcet Sardà2023-02-12 11:38:54 +0100
commit9061a1d40a011a8ade0cba1344671dcc35d118a1 (patch)
tree1e67965673b410f5426679e000be242510a851ca /PKGBUILD
parent9625b96cee8b593c42427414ad948b20600d4f52 (diff)
downloadaur-9061a1d40a011a8ade0cba1344671dcc35d118a1.tar.gz
Upgrade to 1.4.0
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba5c3f727b05..bc8bc4279b9b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer Pol Marcet Sardà <polmarcetsarda@gmail.com>
pkgname=doomseeker
-pkgver=1.3.3.r0.g793919c7
+pkgver=1.4.r0.gd47a5362
pkgrel=1
epoch=1
pkgdesc="A cross-platform Doom server browser"
@@ -11,16 +11,12 @@ license=("LGPL")
depends=('zlib' 'bzip2' 'qt5-tools' 'qt5-base' 'qt5-multimedia')
makedepends=('cmake' 'git')
-optdepends=('qt4: A cross-platform application and UI framework'
- 'zandronum: GZDoom fork supporting client/server multiplayer'
+optdepends=('zandronum: GZDoom fork supporting client/server multiplayer'
'odamex: Classic client/server multiplayer fork'
- 'chocolate-doom: Doom source port accurately reproducing the original DOS versions of Doom'
- 'srb2: A 3D Sonic fan game based off of Doom Legacy (aka "Sonic Robo Blast 2")')
+ 'chocolate-doom: Doom source port accurately reproducing the original DOS versions of Doom')
-source=('doomseeker::git+https://bitbucket.org/Doomseeker/doomseeker#tag=1.3.3'
- 'doomseeker-blobs::git+https://bitbucket.org/Doomseeker/doomseeker-blobs#commit=919add0')
-sha256sums=('SKIP'
- 'SKIP')
+source=('doomseeker::git+https://bitbucket.org/Doomseeker/doomseeker#tag=1.4.0')
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -28,14 +24,11 @@ pkgver() {
}
build() {
- cd "$srcdir/$pkgname-blobs"
- python3 geolite2_conv.py geo/GeoLite2-Country-Blocks-IPv4.csv geo/GeoLite2-Country-Locations-en.csv "$srcdir/$pkgname/src/core/IpToCountry.dat"
cd "$srcdir/$pkgname"
mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DDOOMSEEKER_IP2C_DAT:FILEPATH="IpToCountry.dat" \
..
make
}