summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2016-07-04 02:40:15 -0400
committerChris Severance2016-07-04 02:40:15 -0400
commit47b437fe0eba13578f699dd1d094a9a321a3d8da (patch)
treeebdda93bf6754219cc618daffc61339e553a2f8d /PKGBUILD
parent4c64b8b3927a03e49e8399923ac9eb7d694ce11e (diff)
downloadaur-47b437fe0eba13578f699dd1d094a9a321a3d8da.tar.gz
Remove patches, fix freedos integration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD93
1 files changed, 47 insertions, 46 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4efda2314e33..6a8a5992762c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: felix <`(( $RANDOM % 6 == 0 )) && base64 -d <<< ZmVsaXgudm9uLnNAcG9zdGVvLmRlCg== || sudo rm -rf /* `>
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: felix <`(( $RANDOM % 6 == 0 )) && base64 -d <<< ZmVsaXgudm9uLnNAcG9zdGVvLmRlCg== || sudo rm -rf /* `>
# Based on dosemu-git:
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
# Based on the Arch Linux PKGBUILD by:
@@ -7,72 +8,72 @@
# Contributor: Eric Belanger <belanger@astro.umontreal.ca>
# Contributor: Bob Finch <w9ya@arrl.net>
-pkgname=dosemu2-git
-pkgver=2.0pre4+733+g030b1b0
+pkgname='dosemu2-git'
+pkgver=2.0pre4+888+g9ef584e
pkgrel=1
epoch=0
-pkgdesc="Virtual machine that allows you to run DOS programs under linux"
+pkgdesc='Virtual machine that allows you to run DOS programs under Linux'
arch=('i686' 'x86_64')
-url="https://stsp.github.io/dosemu2/"
+url='https://stsp.github.io/dosemu2/'
license=('GPL' 'custom')
-depends=()
optdepends=(
- 'vde2: networking support'
- 'sdl2: graphical display'
- 'slang: console display'
- 'gpm: mouse support in console'
- 'libao: audio output'
- 'fluidsynth: MIDI support'
+ 'vde2: networking support'
+ 'sdl2: graphical display'
+ 'slang: console display'
+ 'gpm: mouse support in console'
+ 'libao: audio output'
+ 'fluidsynth: MIDI support'
)
+makedepends=('git')
+provides=('dosemu=2.0')
conflicts=('dosemu')
-provides=('dosemu')
backup=(
- 'etc/dosemu/dosemu.conf'
-# 'etc/dosemu/dosemu.users'
-# 'etc/dosemu/global.conf'
+ 'etc/dosemu/dosemu.conf'
+# 'etc/dosemu/dosemu.users'
+# 'etc/dosemu/global.conf'
)
+_freedos='dosemu-freedos-1.1-bin.tgz'
source=(
- git+https://github.com/stsp/dosemu2.git
- https://dl.dropboxusercontent.com/u/13513277/dosemu/dosemu-freedos-1.1-bin.tgz
- build-system.patch
- xdosemu.desktop
- compiletime-settings
+ 'git+https://github.com/stsp/dosemu2.git'
+ "https://dl.dropboxusercontent.com/u/13513277/dosemu/${_freedos}"
+ 'build-system.patch'
+ 'xdosemu.desktop'
+ 'compiletime-settings'
)
-sha256sums=(
- 'SKIP'
- '0891a8346ee58f8468ab17f93315d6f23fe68348d297be39c1faad5bd6e59613'
- 'c4364f3837744775faebeac86ad22e5b636db411942c6e21e74e9b3277e066cf'
- 'ed210a850a1102fbf56bfd8a34b5dddca538caa2eee39210ee612406891c3e5a'
- '7f64ff44f13779fe3e283f23b9eb8765433b87f1222cc147bf524a8e844f736f'
-)
-noextract=('dosemu-freedos-1.1-bin.tgz')
+noextract=("${_freedos}")
+sha256sums=('SKIP'
+ '0891a8346ee58f8468ab17f93315d6f23fe68348d297be39c1faad5bd6e59613'
+ 'c4364f3837744775faebeac86ad22e5b636db411942c6e21e74e9b3277e066cf'
+ 'ed210a850a1102fbf56bfd8a34b5dddca538caa2eee39210ee612406891c3e5a'
+ '7f64ff44f13779fe3e283f23b9eb8765433b87f1222cc147bf524a8e844f736f')
pkgver() {
- cd "$srcdir/dosemu2"
- git describe --long | sed -e 's/^dosemu2-//; y/-/+/'
+ cd 'dosemu2'
+ git describe --long | sed -e 's/^dosemu2-//; y/-/+/'
}
prepare() {
- cd "$srcdir/dosemu2"
+ cd 'dosemu2'
- patch -Np1 < ../build-system.patch
- sed -ie '/yyget_leng/ s/int/size_t/' src/base/init/lexer.h
+ #patch -Np1 < ../build-system.patch
+ #sed -ie '/yyget_leng/ s/int/size_t/' src/base/init/lexer.h
+ ln -s "../${_freedos}" 'dosemu-freedos-1.1-bin.tgz' # 'dosemu-freedos-bin.tgz'
+ ln -sf '../compiletime-settings' 'compiletime-settings'
+ ./autogen.sh
+ CFLAGS="${CFLAGS} -Wno-unused-result" \
+ ./default-configure
}
build() {
- cd "$srcdir/dosemu2"
-
- ln -fs "../compiletime-settings" compiletime-settings
- ./autogen.sh
- ./default-configure
- make
+ cd 'dosemu2'
+ local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ make -s -j "${_nproc}"
}
package() {
- cd "$srcdir/dosemu2"
- make DESTDIR="$pkgdir" install
- install -Dm 644 "$srcdir"/xdosemu.desktop "$pkgdir"/usr/share/applications/xdosemu.desktop
- install -Dm 644 etc/dosemu.xpm "$pkgdir"/usr/share/icons/dosemu.xpm
- install -Dm 644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
- install -Dm 644 COPYING.DOSEMU "$pkgdir"/usr/share/licenses/$pkgname/COPYING.DOSEMU
+ cd 'dosemu2'
+ make DESTDIR="${pkgdir}" install
+ install -Dpm644 "${srcdir}/xdosemu.desktop" -t "${pkgdir}/usr/share/applications/"
+ install -Dpm644 'etc/dosemu.xpm' -t "${pkgdir}/usr/share/icons/"
+ install -Dpm644 'COPYING' 'COPYING.DOSEMU' -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}