summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2022-04-17 15:28:08 -0400
committerChris Severance2022-04-17 15:28:08 -0400
commit8052f83665f95ce02b85abc7efae49c123e32e6a (patch)
treec67f8b33061fdd0d1fc84d945f36470f2b9a277c /PKGBUILD
parent4a1daec2f585aff87ac59f93484ecb92d7566857 (diff)
downloadaur-8052f83665f95ce02b85abc7efae49c123e32e6a.tar.gz
autu: Update to 2.0pre9.dev.r124.g40192ee5a-1 switch back to fdpp
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9b002b38b96..db492f1c69a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ _opt_keepdesktop=0
# 0 = normal
# 1 = install desktop file even in debug modes. This is dangerous as launching sudo in a .desktop crashes the DE
-_opt_fdpp=0
+_opt_fdpp=1
# 0 = use freedos
# 1 = use fdpp and comcom32 (boot only, freedos is still used for utilities)
@@ -33,7 +33,7 @@ _opt_fdpp=0
_pkgname='dosemu2'
pkgname="${_pkgname}-git"
-pkgver=2.0pre8.r2855.gb12525bbd
+pkgver=2.0pre9.dev.r124.g40192ee5a
pkgrel=1
_pkgver="${pkgver%%[a-z]*}"
pkgdesc='Virtual machine that allows you to run DOS programs under Linux'
@@ -157,6 +157,7 @@ _configure() { # makepkg -e compatible
_opts+=('-d' '--enable-debug')
#_opts+=('-d' '--disable-xbacktrace')
fi
+ # export CFLAGS='-O2' # doesn't compile without -O2
if [ "${_opt_clang}" -ne 0 ]; then
_opts+=('CC=clang' 'CXX=clang++')
CFLAGS="${CFLAGS//-fstack-protector-strong/} -fno-stack-protector" # Issue #332
@@ -219,7 +220,7 @@ fi
"${pkgdir}/usr/bin/dosemu"
fi
if [ "${_opt_fdpp}" -ne 0 ]; then
- : find "${pkgdir}" -name 'command.com' -delete # remove files and symlinks
+ find "${pkgdir}" '(' -name 'command.com' -o -name 'kernel.sys' ')' -delete # remove files and symlinks
fi
set +u
}