summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHE Yaowen2023-06-02 21:30:14 +0800
committerHE Yaowen2023-06-02 21:30:14 +0800
commitf3674f61b1273bef8092c646b32bdebaf96a42c3 (patch)
treeca45ca04346296e70f055cc7bfec4a8fe1f5b2b4 /PKGBUILD
downloadaur-f3674f61b1273bef8092c646b32bdebaf96a42c3.tar.gz
Add package description files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55425e3d2405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: HE Yaowen <he.yaowen@hotmail.com>
+
+pkgname=dostron
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="An application to organise your collection of DOS programs for DOSBox."
+arch=("any")
+url="https://github.com/he-yaowen/dostron"
+license=("GPL-3.0")
+depends=("electron")
+source=(https://github.com/he-yaowen/dostron/releases/download/v$pkgver/$pkgname-$pkgver-aur-$arch.tar.xz)
+sha256sums=("a5887cc8ea1dd0aec5f032929a527093c6d0afc967b4088cc3871666dd0fc9df")
+
+build() {
+ mkdir -p $srcdir/opt
+ mkdir -p $srcdir/usr/bin
+ mkdir -p $srcdir/usr/share/applications
+
+ tar -xvf $pkgname-$pkgver-aur-$arch.tar.xz -C $srcdir/opt
+
+ cat > $srcdir/usr/bin/dostron <<EOF
+#!/bin/bash
+exec electron /opt/$pkgname-$pkgver/app.asar
+EOF
+ chmod +x $srcdir/usr/bin/dostron
+
+ cat > $srcdir/usr/share/applications/$pkgname.desktop <<EOF
+[Desktop Entry]
+Name=Dostron
+Version=$pkgver
+Comment=An application to organise your collection of DOS programs for DOSBox.
+Type=Application
+Exec=dostron
+Icon=/opt/$pkgname-$pkgver/dostron.png
+Terminal=false
+StartupNotify=false
+Categories=Application;Game;
+EOF
+}
+
+package() {
+ cp -r $srcdir/opt $pkgdir
+ cp -r $srcdir/usr $pkgdir
+} \ No newline at end of file