summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Dorst2022-07-20 01:58:17 -0700
committerMichael Dorst2022-07-20 01:58:17 -0700
commit7e75b42f379f02c3bc502a5a0264452420d54c64 (patch)
tree91a0fb85e8c97a002f4e6493580bc9c9cf15d732 /PKGBUILD
downloadaur-7e75b42f379f02c3bc502a5a0264452420d54c64.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e8d37587dfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Michael Dorst <m@mdorst.net>
+pkgname=dotconfig
+pkgver=0.1.2
+pkgrel=1
+sha256sums=('27cdd270acd2c1d01329b8907a9e1fe361e1f68c417ac22209008587d79f5a39')
+makedepends=('cargo')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="A tool for symlinking configuration files from a central repository to their respective locations on the system in a repeatable, configurable way."
+url="https://github.com/mfdorst/dotconfig"
+source=(${pkgname}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz)
+license=('MIT')
+_archive="${pkgname}-${pkgver}"
+
+# Generated in accordance to https://wiki.archlinux.org/title/Rust_package_guidelines.
+# Might require further modification depending on the package involved.
+prepare() {
+ cd "${_archive}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${_archive}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "${_archive}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "${_archive}"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}