summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordeadc0de62018-02-11 12:50:29 +0100
committerdeadc0de62018-02-11 12:50:29 +0100
commit49e8be5317e3f9b5152310b799414f6633f844cc (patch)
tree28e33f7dd6b8d4d262afa5b8a961dd61a70861ec /PKGBUILD
parent861c8316795592f67b62beafa3c716aab159fe26 (diff)
downloadaur-49e8be5317e3f9b5152310b799414f6633f844cc.tar.gz
get latest release and fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad427cf9c091..4fe70bae2e10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,18 @@ arch=('any')
url="https://github.com/deadc0de6/dotdrop"
license=('GPL')
groups=()
-depends=('python' 'python-jinja' 'python-docopt' 'python-pyaml')
-source=("git+https://github.com/deadc0de6/dotdrop.git")
+depends=('python' 'python-setuptools' 'python-jinja' 'python-docopt' 'python-pyaml')
+makedepends=('git')
+source=("git+https://github.com/deadc0de6/dotdrop.git#tag=v${pkgver}")
md5sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ git describe --abbrev=0 --tags | sed 's/^v//g'
+}
+
package() {
cd "${pkgname}"
- python setup.py install --root="${pkgdir}/"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}