summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGithub Actions2020-09-04 16:38:55 +0000
committerGithub Actions2020-09-04 16:38:55 +0000
commit66f0b7507212915964c9f3076afb9cbb32c0af76 (patch)
tree316a25cdcd851c5e9c8230c371e5f99ffd3e4706 /PKGBUILD
parentc22e0783b46c69522e5adbe2b827aab466cb143f (diff)
downloadaur-66f0b7507212915964c9f3076afb9cbb32c0af76.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f765c0e46eb4..3c0c91f2eddb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Kobus van Schoor <v dot schoor dot kobus at gmail dot com>
pkgname=dotgit
-pkgver=1.4.4
-pkgrel=1
-pkgdesc="A comprehensive solution to managing your dotfiles"
-url="http://github.com/kobus-v-schoor/dotgit"
+pkgver='2.1.0'
+pkgrel=0
+pkgdesc='A comprehensive solution to managing your dotfiles'
+url='https://github.com/kobus-v-schoor/dotgit'
arch=('any')
-depends=('git' 'bash' 'gnupg')
-source=('git+https://github.com/kobus-v-schoor/dotgit.git')
+depends=('git' 'python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/d/dotgit/dotgit-$pkgver.tar.gz")
md5sums=('SKIP')
-prepare()
+build()
{
- cd $pkgname
- git --work-tree . checkout -q tags/$pkgver
+ cd "dotgit-$pkgver"
+ python setup.py build
}
package()
{
- install -Dm 755 "$srcdir/dotgit/bin/dotgit" "$pkgdir/usr/bin/dotgit"
- cp -r "$srcdir/dotgit/bin/dotgit_headers" "$pkgdir/usr/bin/dotgit_headers"
- chmod 555 "$pkgdir/usr/bin/dotgit_headers"
- install -Dm644 "$srcdir/dotgit/bin/bash_completion" \
+ cd "dotgit-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 pkg/completion/bash.sh -T \
"$pkgdir/usr/share/bash-completion/completions/dotgit"
}