summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKobus van Schoor2015-12-28 14:58:43 +0200
committerKobus van Schoor2015-12-28 14:58:43 +0200
commit79aa6e4d9f382afec401ce7ba6b96dd813bd8daa (patch)
treef74e04dec8207a39d36e0271b5e1bb02f3ccf89e /PKGBUILD
parentc8159e313ec69c29e02d2b9655ce28ce4bb5a3d1 (diff)
downloadaur-79aa6e4d9f382afec401ce7ba6b96dd813bd8daa.tar.gz
Updated pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae6bf351ebbe..58995ceed4a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,11 @@ depends=('git' 'sed' 'grep' 'bash' )
source=('git+https://github.com/Cube777/dotgit.git')
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
package() {
install -Dm755 "$srcdir/$pkgname/dotgit" "$pkgdir/usr/bin/dotgit"
}