summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAttila Greguss2019-10-03 23:56:30 +0100
committerAttila Greguss2019-10-03 23:56:30 +0100
commitf1c5fb710ed9a152223bee1fd5005903f6829f0b (patch)
tree7b2733b8b6a2684266b4941c88d8c470369051fb /PKGBUILD
parent7f5328adeb6bef2a46cde1b3f4c67b8cc2628941 (diff)
downloadaur-f1c5fb710ed9a152223bee1fd5005903f6829f0b.tar.gz
Add dotnet-runtime-bin back in
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffa23ed8819d..4c7aaebf2d15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
pkgbase=dotnet-core-bin
-pkgname=('dotnet-host-bin' 'aspnet-runtime-bin' 'dotnet-sdk-bin')
+pkgname=('dotnet-host-bin' 'dotnet-runtime-bin' 'aspnet-runtime-bin' 'dotnet-sdk-bin')
pkgver=3.0.100
-pkgrel=2
+pkgrel=3
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
@@ -32,19 +32,17 @@ package_dotnet-host-bin() {
install -Dm 755 "${srcdir}"/dotnet.sh "${pkgdir}"/usr/bin/dotnet
}
+package_dotnet-runtime-bin() {
+ pkgdesc='The .NET Core runtime (binary)'
+ depends=('dotnet-host-bin' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
+ 'libcurl.so')
+ optdepends=('lttng-ust: CoreCLR tracing')
+ provides=("dotnet-runtime=${pkgver%+*}")
-# runtime-bin already exists in aur, but incomplete
-#package_dotnet-runtime-bin() {
-# pkgdesc='The .NET Core runtime (binary)'
-# depends=('dotnet-host-bin' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
-# 'libcurl.so')
-# optdepends=('lttng-ust: CoreCLR tracing')
-# provides=("dotnet-runtime=${pkgver%+*}")
-
-# install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
-# cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/opt/dotnet/shared/
-# ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-runtime
-#}
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-runtime
+}
package_aspnet-runtime-bin() {
pkgdesc='The ASP.NET Core runtime (binary)'