summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2017-02-21 19:07:19 -0500
committerTony Lambiris2017-02-21 19:07:19 -0500
commit43011f3db92ffe37e4a2b915c12e288f2b7b1901 (patch)
tree5d73d38cb310723cd22ea580fe2465ccee6c3d37 /PKGBUILD
downloadaur-43011f3db92ffe37e4a2b915c12e288f2b7b1901.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a02219cb2f51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com
+
+pkgname=double-conversion
+pkgver=2.0.1.r68.gd8d4e66
+pkgrel=1
+pkgdesc='Efficient binary-decimal and decimal-binary conversion routines for IEEE doubles.'
+arch=(i686 x86_64)
+url='https://github.com/google/double-conversion'
+license=(BSD)
+conflicts=()
+provides=()
+replaces=()
+depends=()
+makedepends=(git scons cmake)
+source=(git+https://github.com/google/double-conversion.git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${srcdir}"/double-conversion
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}"/double-conversion
+ cmake -Wno-dev \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+check() {
+ cd "${srcdir}"/double-conversion
+ make test
+}
+
+package() {
+ cd "${srcdir}"/double-conversion
+ make DESTDIR="$pkgdir" install
+}