summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpatrick brisbin2015-06-09 17:20:08 -0400
committerpatrick brisbin2015-06-09 17:20:08 -0400
commit0bdb507e2793e8d22a0738d03b38e479f55c9669 (patch)
tree9b0cb460d6e201312941e801b80e9b9573436e46 /PKGBUILD
downloadaur-0bdb507e2793e8d22a0738d03b38e479f55c9669.tar.gz
Initial commit of v5.1.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c67882c2008
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Author: Patrick Brisbin <pbrisbin@gmail.com>
+pkgname=downgrade
+pkgver=5.1.3
+pkgrel=1
+pkgdesc="Bash script for downgrading one or more packages to a version in your cache or the A.R.M."
+arch=('any')
+url="https://github.com/pbrisbin/$pkgname"
+license=('GPL')
+source=("https://github.com/pbrisbin/$pkgname/archive/v$pkgver.tar.gz")
+optdepends=('sudo: for installation via sudo')
+
+package() {
+ local po_file
+
+ cd "$pkgname-$pkgver"
+
+ for po_file in locale/*.po; do
+ locale="$(basename "$po_file" .po)"
+
+ mkdir -p "$pkgdir/usr/share/locale/$locale/LC_MESSAGES/"
+ msgfmt "$po_file" -o "$pkgdir/usr/share/locale/$locale/LC_MESSAGES/$pkgname.mo"
+ done
+
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+md5sums=('37e82c18f56e8f0343b57edf7bf4e687')